This is a migrated thread and some comments may be shown as answers.

RadToolTip not showing up when using RadFormDecorator

2 Answers 58 Views
ToolTip
This is a migrated thread and some comments may be shown as answers.
Marie
Top achievements
Rank 1
Marie asked on 08 Jan 2009, 04:54 PM
Hello,

I have a RadToolTip which should be displayed when the mouse hovers over an asp button.  When I use a RadFormDecorator to set the skin of the button, the RadToolTip does not appear when it mouses over the button.  If I exclude the button from the RadFormDecorator's DecoratedControls or set a DecorationZoneID to exlude the button, the RadToolTip behaves as expected and appears on mouse over.  Is this a bug or is this behaviour by design?  Is there anything I can do to use both a RadToolTip and a RadFormDecorator for the same control?

Thanks,
Marie

2 Answers, 1 is accepted

Sort by
0
Accepted
Svetlina Anati
Telerik team
answered on 09 Jan 2009, 12:05 PM
Hello Marie,

What actually happens in your particular case is that the real button is made invisible and a fake one is created due to decorating it with the RadFormDecorator. The RadToolTip "searches" for the already invisible button and that is the reason for the problem.

We are aware of this problem when using RadFormDecorator in integration with RadToolTip and it is already fixed - the fix will be available in our next release of SP2 which is scheduled for next week.

Kind regards,
Svetlina
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Marie
Top achievements
Rank 1
answered on 09 Jan 2009, 01:54 PM
Thanks for the quick reply Svetlina!
Tags
ToolTip
Asked by
Marie
Top achievements
Rank 1
Answers by
Svetlina Anati
Telerik team
Marie
Top achievements
Rank 1
Share this question
or