RadNumericInput autocomplete

2 posts, 0 answers
  1. Raffy
    Raffy avatar
    4 posts
    Member since:
    Mar 2009

    Posted 27 Mar 2009 Link to this post

    Hi.

    The company I am working uses the RadNumericInput control with it's language set to Danish (Denmark).

    The problem occurs when you click from the RadNumericInput's autocomplete dropdown.
    When I doubleclick the RadNumericInput control,  I have these numbers listed in the autocomplete dropdown.

    400.000
    444444
    444.444
    500.000
    555.555

    If I select a number and lost focus from the RadNumericInput control, the following happens.

    400.000 -> 400                         // any characters starting from the thousand separator to the end of the entry are being
                                                         disregarded if it contains zeroes.
    444444  -> 444 444                  // the value was formatted but the thousand separator becomes space character
    444.444  -> 444 444                 // the thousand separator becomes space character
    500.000  -> 500                        // any characters starting from the thousand separator to the end of the entry are being
                                                         disregarded if it contains zeroes.
    555.555  -> 555 555                 // the thousand separator becomes space character

    Is there any way to fix this?

    Thank you and best regards,
    Raffy

  2. Daniel
    Admin
    Daniel avatar
    4949 posts

    Posted 27 Mar 2009 Link to this post

    Hello Raffy,

    You can disable the autocomplete as shown below:
    <telerik:RadNumericTextBox ID="RadNumericTextBox1" runat="server" autocomplete="off" /> 

    Best regards,
    Daniel
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Back to Top