This is a migrated thread and some comments may be shown as answers.

RadListView issue

2 Answers 41 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Kamal Mostofi
Top achievements
Rank 1
Kamal Mostofi asked on 06 May 2010, 11:15 PM
Hi,

I followed the example from your demo page. I am trying to display images as sushi page. I like to do the following:

  1. Display 10 images
  2. Select an image
  3. navigate through each page on listview

The problem I have is that each time I navigate through the page, my asp page reload itself and doesn't use ajax method.
Could you please tell me what I am missing here?
Please see the code below
'Format Code Block'(<asp:ObjectDataSource ID="dslogo" runat="server"

 

 

 

 

 

OldValuesParameterFormatString="original_{0}"

 

 

 

 

 

 

 

SelectMethod="ListImages"

 

 

 

 

 

 

 

TypeName="logosBLL.logo" >

 

 

 

 

 

 

 

 

</asp:ObjectDataSource>

 

 

 

 

 

 

 

 

<telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">

 

 

 

 

 

 

 

 

<AjaxSettings>

 

 

 

 

 

 

 

 

<telerik:AjaxSetting AjaxControlID="SushiPanel">

 

 

 

 

 

 

 

 

<UpdatedControls>

 

 

 

 

 

 

 

 

<telerik:AjaxUpdatedControl ControlID="SushiPanel" LoadingPanelID="RadAjaxLoadingPanel1" />

 

 

 

 

 

 

 

 

</UpdatedControls>

 

 

 

 

 

 

 

 

</telerik:AjaxSetting>

 

 

 

 

 

 

 

 

</AjaxSettings>

 

 

 

 

 

 

 

 

</telerik:RadAjaxManager>

 

 

 

 

 

 

 

 

<telerik:RadAjaxLoadingPanel ID="RadAjaxLoadingPanel1" runat="server" Skin="Black">

 

 

 

 

 

 

 

 

</telerik:RadAjaxLoadingPanel>

 

 

 

 

 

 

 

 

<telerik:RadListView ID="RadListView1" runat="server" DataSourceID="dslogo"

 

 

 

 

 

 

 

 

ItemPlaceholderID="PlaceHolder1" AllowPaging="true">

 

 

 

 

 

 

 

 

<LayoutTemplate>

 

 

 

 

 

 

 

 

<div class="sushibar">

 

 

 

 

 

 

 

 

<asp:Panel ID="SushiPanel" runat="server">

 

 

 

 

 

 

 

 

<div class="sushi">

 

 

 

 

 

 

 

 

<asp:PlaceHolder ID="PlaceHolder1" runat="server"></asp:PlaceHolder>

 

 

 

 

 

 

 

 

</div>

 

 

 

 

 

 

 

 

<telerik:RadDataPager ID="RadDataPager1" runat="server" PageSize="10" Skin="Black">

 

 

 

 

 

 

 

 

<Fields>

 

 

 

 

 

 

 

 

<telerik:RadDataPagerButtonField />

 

 

 

 

 

 

 

 

</Fields>

 

 

 

 

 

 

 

 

</telerik:RadDataPager>

 

 

 

 

 

 

 

 

</asp:Panel>

 

 

 

 

 

 

 

 

</div>

 

 

 

 

 

 

 

 

</LayoutTemplate>

 

 

 

 

 

 

 

 

<ItemTemplate>

 

 

 

 

 

 

 

 

<div class="category">

 

 

 

 

 

 

 

 

<asp:Image runat="server" ID="imglogo2" Height="70px" Width="70px" ImageUrl='<%# Eval("logopath") %>' />

 

 

 

 

 

 

 

 

</div>

 

 

 

 

 

 

 

 

</ItemTemplate>

 

 

 

 

 

 

 

 

<SelectedItemTemplate>

 

 

 

 

 

 

 

 

<div class="selected">

 

 

 

 

 

 

 

 

<asp:Image runat="server" ID="imglogo2" Height="70px" Width="70px" ImageUrl='<%# Eval("logopath") %>' />

 

 

 

 

 

 

 

 

</div>

 

 

 

 

 

 

 

 

</SelectedItemTemplate>

 

 

 

 

 

 

 

 

</telerik:RadListView>

 

 

 

 

 

 

)

And also I get the following warning in my project:
Warning 6 Reference to type 'System.Web.UI.WebControls.IPageableItemContainer' claims it is defined in 'd:\Visual Studio 2010\Projects\wave10\wave10\bin\System.Web.Extensions.dll', but it could not be found c:\Program Files (x86)\Telerik\RadControls for ASP.NET AJAX Q1 2010\Bin35\Telerik.Web.UI.dll wave3

Many thanks in advance
Kamal

2 Answers, 1 is accepted

Sort by
0
Accepted
Veli
Telerik team
answered on 11 May 2010, 04:24 PM
Hi Kamal,

Thanks for the sample code. I can see it's almost identical to the RadListView Sushi demo you are referring to. I cannot spot any misconfiguration. Your RadControls for ASP.NET AJAX installation package should also come with a local copy of the Quick Start demo application that you can see live. You can open the application and test it locally. Your listview and AJAX manager definitions seem identical.

If the problem persists, consider opening a regular support ticket where you can send us a sample project we can run locally. This will help us in identifying the source of this issue and will enable to assist you further.

Greetings,
Veli
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Kamal Mostofi
Top achievements
Rank 1
answered on 12 May 2010, 05:24 PM
Hi,
The problem was related to System.Web.Extension version. The previous version was targeting .net 2, but when I upgraded my project to VS 2010 and using the latest version of Telerik tools, I missed to update System.Web.Extension to .net 3.5.

When I made the chanegs, it works fine without any postback or flicking page.

Thanks,
Kamal
Tags
General Discussions
Asked by
Kamal Mostofi
Top achievements
Rank 1
Answers by
Veli
Telerik team
Kamal Mostofi
Top achievements
Rank 1
Share this question
or