Radgrid footer row with a hidden column has wrong column span for the first cell

4 posts, 0 answers
  1. s
    s avatar
    4 posts
    Member since:
    Jan 2015

    Posted 29 Sep 2015 Link to this post

    Hi,

    I am using Telerik Radgrid version 2014.1.403.40

    My grid has 1 level of DetailTables. I am hiding the datakey column that links this with the master tab​le. 

    I cannot update Telerik or apply any patch. How can I get around with the issue above? It shows up for IE versions

    8 and lower.

     Thanks in advance.

     

     

  2. Eyup
    Admin
    Eyup avatar
    3666 posts

    Posted 02 Oct 2015 Link to this post

    Hello,

    What exactly is the issue? How do you hide the column? If you are using Visible, you can try to use Display instead and vice versa.

    Regards,
    Eyup
    Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. s
    s avatar
    4 posts
    Member since:
    Jan 2015

    Posted 02 Oct 2015 in reply to Eyup Link to this post

    <telerik:GridBoundColumn SortExpression="​xxxxx" HeaderText="xxxxxxxxxxxxxx" HeaderButtonType="TextButton"  Display="false" Aggregate="None" UniqueName="xxxxxxxxxxx"
                        DataField="​xxxxx" FooterStyle-HorizontalAlign="Right" >

    This is how I am hiding the column and the footer row shifts in IE 8 and lower, but looks right in higher versions.

    Thanks  Eyup.

     

     

     

  4. s
    s avatar
    4 posts
    Member since:
    Jan 2015

    Posted 02 Oct 2015 in reply to s Link to this post

    Eyup, that worked like a charm. I replaced the Display property with Visible except the rgExpand column now appears a bit wider

    but I think I can live with it. Thanks a lot !!!!!!!

Back to Top