This is a migrated thread and some comments may be shown as answers.

RadGrid client rendering on IE6 very slow

5 Answers 133 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Emilian D
Top achievements
Rank 1
Emilian D asked on 16 Jan 2009, 08:33 AM
I have a RadGrid with maximum of 2000 elements and page size is 200. I can't change the page size.
The grid has 30 columns.
On IE6, it takes 5 seconds to render this grid. On IE7/FF3 it is better, but still takes 1-2 s to render.
It is a client rendering problem, because this time of 5 seconds is between the data is shown in the grid and the time when you may action on the grid.
Also, the grid has a horizontal scroll and while rendering, it display all the columns and no scrolling bar, which is ugly.
What i may do to improve the rendering time.
1. It must be 200 rows on a page.
2. the grid definition:
AllowFilteringByColumn="True"
                AllowMultiRowSelection="True" AllowPaging="True" AllowSorting="True" EnableAJAX="True"
                GridLines="None" Skin="Blue" AutoGenerateColumns="False" OnNeedDataSource="lgSelectGrid_NeedDataSource"
                EnableAJAXLoadingTemplate="True" EnableOutsideScripts="False" PageSize="200"
                Height="400px" EnableViewState="true" Width="100%" meta:resourcekey="lgSearchedGridResource1"
                OnSelectedIndexChanged="lgSearchedGrid_SelectedIndexChanged" OnPageIndexChanged="lgSearchedGrid_PageIndexChanged"
                OnSortCommand="lgSearchedGrid_SortCommand">
                <ClientSettings EnableClientKeyValues="True">
                    <Selecting AllowRowSelect="True"></Selecting>
                    <Scrolling AllowScroll="True" UseStaticHeaders="True"></Scrolling>
                    <Resizing AllowColumnResize="True"></Resizing>
                </ClientSettings>
                <ItemStyle Wrap="True"></ItemStyle>
                <FilterItemStyle Wrap="True"></FilterItemStyle>
                <MasterTableView OnPreRender="lgSearchedGrid_PreRender" DataSourcePersistenceMode="NoPersistence"
                    DataKeyNames=Id1,Id2 TableLayout="Fixed" Width="100%">
                    <RowIndicatorColumn Visible="False">
                        <HeaderStyle Width="20px"></HeaderStyle>
                    </RowIndicatorColumn>
                    <ExpandCollapseColumn Visible="False" Resizable="False">
                        <HeaderStyle Width="20px"></HeaderStyle>
                    </ExpandCollapseColumn>

Any suggestion will be great.
Thanks.

5 Answers, 1 is accepted

Sort by
0
Accepted
Dimo
Telerik team
answered on 16 Jan 2009, 09:32 AM
Hello,

If decreasing the number of rows and columns is not an option, then please set

1) UseStaticHeaders="false"

Static headers require RadGrid to readjust its layout on the client, which is a DOM-intense operation and given the slow Javascript engine of Internet Explorer, a lag is observed.

2) remove the RadGrid Height property and use ScrollHeight instead

This will completely prevent RadGrid from resizing on the client (height-wise)

<Scrolling AllowScroll="true" UseStaticHeaders="false" ScrollHeight="400px" />


All the best,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Emilian D
Top achievements
Rank 1
answered on 16 Jan 2009, 10:54 AM
Thank you a lot for your answer.
It seems that:
1) StaticHeader="false" is not an option, because they want to keep the header on scrolling.
2) ScrollHeight, it improved a little the speed.

Any other suggestions?
Thanks.
0
Dimo
Telerik team
answered on 16 Jan 2009, 11:29 AM
Hello,

No, these two suggestions were the most important ones. The other features are not so resource heavy as the static headers during client-side initialization.

Greetings,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Ashwin Deshpande
Top achievements
Rank 1
answered on 11 Aug 2010, 07:08 AM
I am also facing the same problem.Radgrid in IE7 works fine whereas in IE6 its is very slow,
I also want my headers fixed any solution for this....im using Radgrid Q32008
0
Dimo
Telerik team
answered on 11 Aug 2010, 07:52 AM
Hello Ashwin,

Apart from the suggestions above, you can reduce the PageSize (if paging is used) or use server-side hierarchy load mode instead of client-side (if hierarchy is used).

Sincerely yours,
Dimo
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Grid
Asked by
Emilian D
Top achievements
Rank 1
Answers by
Dimo
Telerik team
Emilian D
Top achievements
Rank 1
Ashwin Deshpande
Top achievements
Rank 1
Share this question
or