This is a migrated thread and some comments may be shown as answers.

RadGrid - cannot edit rows when the page (default.aspx) is not specified in the address

4 Answers 20 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Fanie
Top achievements
Rank 1
Fanie asked on 11 Mar 2019, 01:05 PM

I have a web application, with a RadGrid on the default page, published on IIS 10.

When I browse to the application using http://mywebapp it opens up, but I nothing happens when clicking on the edit button on any of the rows in the RadGrid.  When troubleshooting with Fiddler I receive 500 Internal Server Error.

If I include the page name in the address, i.e. http://mywebapp/default.aspx, editing works as expected.

I don't want to include the page name every time I browse to my web application, is there a way to solve this?

4 Answers, 1 is accepted

Sort by
0
Fanie
Top achievements
Rank 1
answered on 13 Mar 2019, 01:30 PM

Attached is the error I get when troubleshooting with developer tools (F12) in Chrome.  It seems to be a problem with the WebResource.axd file.

 

Any ideas?

0
Fanie
Top achievements
Rank 1
answered on 14 Mar 2019, 06:30 AM

I found the following Warning message in the Application event log:

Message
Object reference not set to an instance of an object.
Stack Trace
   at System.Object.GetType()
   at Telerik.Web.UI.RadCompression.Compress(HttpApplication application)
   at Telerik.Web.UI.RadCompression.PreRequestHandlerExecute(Object sender, EventArgs e)
   at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

On further searching I found this thread on Telerik's forums which solved my problem.  https://www.telerik.com/forums/radcompression-throws-nullreferenceexception

I removed the runAllManagedModulesForAllRequests="true" declaration in the modules section and added the preCondition="managedHandler" for the RadCompression module

 

 

0
Fanie
Top achievements
Rank 1
answered on 14 Mar 2019, 06:31 AM
0
Eyup
Telerik team
answered on 14 Mar 2019, 07:06 AM
Hi Fanie,

The error indicates that you have enabled AJAX on the page which is hiding the real error behind it. You can temporarily disable AJAX. This should give you more details about the error so you can better track and troubleshoot it:
https://www.telerik.com/support/kb/aspnet-ajax/ajaxmanager/details/get-more-descriptive-errors-by-disabling-ajax

One of the messages says 500 Internal Error. My guess would be that a different URL might affect some links on the page, which can be related to the current location. You could have some web service data which is not accessible due to this reason.

Regards,
Eyup
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Grid
Asked by
Fanie
Top achievements
Rank 1
Answers by
Fanie
Top achievements
Rank 1
Eyup
Telerik team
Share this question
or