RadEditor Width problem

6 posts, 0 answers
  1. iHire iHire
    iHire iHire avatar
    2 posts
    Member since:
    Mar 2010

    Posted 18 May 2010 Link to this post

    Just for some background information, I am using a RadEditor inside of a MultiView with several different Views.  The sixth view is the one that contains the RadEditor.  The first couple Views contain question and answers that fill the RadEditor Content. 

    When the view with the RadEditor is displayed sometimes the RadEditor box will have the width of the longest paragraph on one line and creates a horizontal scroll.  In addition all the text in the RadEditor is not displayed.  Other times the RadEditor displays the same content without a horiztonal scroll for a with of 1000px.  In addition the text is completely there. 

    I have tried setting the width on the front end and back end code to 1000px but it occasionally displays as extremely wide.  I have also tried putting a div or a table around the RadEditor with the fixed with of 1000px with the same result.  Has anybody seen this?  Does anybody have any suggestions?


    Thanks
  2. Rumen
    Admin
    Rumen avatar
    14366 posts

    Posted 21 May 2010 Link to this post

    Hi iHire iHire,

    The reported problem should be fixed in the latest Q1 2010 SP2 build of RadEditor. If you are using an older version and could not upgrade at this moment try the code solution provided in this forum thread:
    Bug in Firefox: RadEditor on RadMultiPage + RadTabStrip.

    Best regards,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. iHire iHire
    iHire iHire avatar
    2 posts
    Member since:
    Mar 2010

    Posted 21 May 2010 Link to this post

    Rumen,
     
    I am just starting to use this product with AJAX so updating dlls wouldnt be a problem at all.  The product version number on my Telerik.Web.UI.dll is 2010.1.415.35.  Is the Q1 SP2 version that you were talking about.  I dont see any where on the dll what SP it is.

    Thanks,
    Gary
  4. Rumen
    Admin
    Rumen avatar
    14366 posts

    Posted 21 May 2010 Link to this post

    Hi Gary,

    You can see a list of all releases and their version at http://www.telerik.com/products/aspnet-ajax/whats-new/release-history.aspx.

    In case the provided solution in the forum thread does not help, please open a support ticket and send us a sample working project that demonstrates the problem.

    Best regards,
    Rumen
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. warren
    warren avatar
    6 posts
    Member since:
    May 2011

    Posted 18 Mar 2012 Link to this post

    hi there, i am too having the same problem with a radeditor width. after trying the onclientinit script and some other css settings i cannot get rid of the horizontal scroll in the editor content 

    is there any fix for this ?
     
  6. Rumen
    Admin
    Rumen avatar
    14366 posts

    Posted 21 Mar 2012 Link to this post

    Hello,

    Since the shared information is not enough to determine your specific scenario, please open a support ticket and provide a simple working project which demonstrates the problem.

    My suggestion is to test the latest Q1 2012 version of Telerik.Web.UI.dll as well as check for global CSS styles on the page which could apply overflow: scroll to the content area of RadEditor.

    Best regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top