RADEDITOR upload buttons missing text

6 posts, 1 answers
  1. Vinícius
    Vinícius avatar
    3 posts
    Member since:
    Jan 2014

    Posted 02 Jan 2014 Link to this post

    Hi, 
    The value in Html is empty.

    <input type="button" value="" class="ruButton ruBrowse" tabindex="0">

    We appreciate any feedback and suggestions.
  2. Dobromir
    Admin
    Dobromir avatar
    1633 posts

    Posted 03 Jan 2014 Link to this post

    Hello,

    The provided information is not enough to determine the exact cause of the described issue. Could you please provide more detailed information regarding specific scenario?
    • Which version of RadControls for ASP.NET AJAX and .NET Framework are used in the application?
    • Under which browser and its version the problem occurs?
    • Could you please provide a simple fully runnable project and the steps that need to be executed to reproduce the problem so we can investigate it further?

    A possible reason for such behaviour might be an invalid localization. If you have set a custom localization to RadEditor, could you please try to remove it and see if the problem still exists?


    Looking forward to hearing from you,
    Dobromir
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. Vinícius
    Vinícius avatar
    3 posts
    Member since:
    Jan 2014

    Posted 03 Jan 2014 Link to this post

    • I not sure about the version but in DLL is 2012.2.607.35.
    • This occurs in all browsers
    • In the RadEditor when i click in the upload image.

    I checked the localization of files and its ok 


  4. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 06 Jan 2014 Link to this post

    Hi,

    Please have a look into the sample code snippet which works fine at my end.

    ASPX:
    <telerik:RadEditor DocumentManager-EnableAsyncUpload="true" ID="RadEditor1" runat="server"
        TemplateManager-EnableAsyncUpload="true" TemplateManager-DeletePaths="~/view/"
        TemplateManager-UploadPaths="~/uplods/" TemplateManager-ViewPaths="~/uplods/">
    </telerik:RadEditor>

    Please provide your code if it doesn't help you.
    Thanks,
    Shinu.
  5. Vinícius
    Vinícius avatar
    3 posts
    Member since:
    Jan 2014

    Posted 06 Jan 2014 Link to this post

    <telerik:RadEditor ID="editorConteudo" runat="server" Width="850px" Height="400px" EnableTextareaMode="false"
        Language="pt-BR" ToolsFile="~/RadControls/CustomEditor.xml" ContentFilters="None"  EditorContentFilters="DefaultScripts"
        LocalizationPath="~/RadControls/Editor/Resources" ImageManager-MaxUploadFileSize="716800"  
    FlashManager-MaxUploadFileSize="716800" MediaManager-MaxUploadFileSize="716800"  ToolbarMode="Default"  AllowScripts="True"
    EnableEmbeddedScripts="true" EditModes="All" ViewStateMode="Disabled"  ToolsWidth="850px">
                           <Content>
                           </Content>
                            <Tools>
                            </Tools>
    </telerik:RadEditor>
    I used your example but got the same problem
    Thank you,
    Vinicius Sene Todesco
  6. Answer
    Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 06 Jan 2014 Link to this post

    Hi,

    Please try to set the EnableAsyncUpload Property of RadEditor FileManagers. Please try the following modification that I did on your code and which works fine at my end. Please have a look into this Flash Manager Dialog document and this online demo for more information.

    ASPX:
    <telerik:RadEditor ID="editorConteudo" runat="server" Width="850px" Height="400px"
        EnableTextareaMode="false" Language="pt-BR" ContentFilters="None" EditorContentFilters="DefaultScripts"
        FlashManager-MaxUploadFileSize="716800" FlashManager-EnableAsyncUpload="true"
        FlashManager-DeletePaths="~/view/" FlashManager-UploadPaths="~/uplods/" FlashManager-ViewPaths="~/uplods/"
        ToolbarMode="Default" AllowScripts="True" EnableEmbeddedScripts="true" EditModes="All"
        ViewStateMode="Disabled" ToolsWidth="850px">
    </telerik:RadEditor>

    Hope this will helps you.
    Thanks,
    Shinu.
Back to Top