RadEditor preview displays 'RadEditor - please enable JavaScript to use the rich text editor'

5 posts, 0 answers
  1. Sameer
    Sameer avatar
    8 posts
    Member since:
    Mar 2011

    Posted 09 Apr 2012 Link to this post

    Hello,

    I see a weird message 'RadEditor - please enable JavaScript to use the rich text editor' in a grey textbox below the RadEditor in preview mode. The actual content of the RadEditor is also displayed as blank. Could someone please let me know the solution for the same?

    Regards,
    Sameer
  2. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 10 Apr 2012 Link to this post

    Hi,

    Please, see the following forum thread on the subject: "RadEditor - please enable JavaScript to use the rich text editor" message in RadEditor.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Sameer
    Sameer avatar
    8 posts
    Member since:
    Mar 2011

    Posted 10 Apr 2012 Link to this post

    Rumen,

    Thanks for the response. I did see this suggested post earlier but unfortunately it's not helping to fix our issue.

    It seems like <noscript> is getting appended in our code and with RadEditor disabled, it gets rendered fine.
    However, when it's in Preview mode it looks like is expecting JavaScript to be available to render. Would
    you be able please explain why javascript is needed in Preview mode?

  4. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 11 Apr 2012 Link to this post

    Hi Sameer,

    Do you mean Preview mode of RadEditor or enabled="false" mode of RadEditor. When the editor is placed in Preview mode its scripts are loaded because it is still possible to switches the modes and modify the content. When the editor is placed in content preview only (Enabled="false") mode, its contents are rendered in a standard DIV element and the editor's scripts are not loaded on the page.

    My suggestion is to download and try the latest version of Telerik.Web.UI, which we will release later today. If the problem still persists, isolate it in a simple working project and send it for examination via a support ticket.


    Kind regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  5. Sameer
    Sameer avatar
    8 posts
    Member since:
    Mar 2011

    Posted 11 Apr 2012 Link to this post

    Hi Rumen,

    As of now, I am using a work-around by just making RadEditor enabled property to false instead of using preview for <noscript> scenarios. I was hoping to make a fix with the existing version of Telerik.Web.UI since we don't want to deploy latest version without proper testing. We will may be trying with latest version bit later. In the meantime, if you come across any alternate fix, please let us know. Thanks for your help.

    Regards,
    Sameer
Back to Top