Radeditor changes html content

7 posts, 0 answers
  1. Ash
    Ash avatar
    14 posts
    Member since:
    Mar 2012

    Posted 02 Mar 2012 Link to this post

    Is there a setting through which the radeditor does not change the content at all??

    if my user enter's
    <test>
    </test>
    i want it to remain so and not change to
    <test />

    This happen's on postback (of the other button's which are there on the page) as well as on save button click. i am new to radeditor, could you please help me out?

  2. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 05 Mar 2012 Link to this post

    Hello,

    If you experience this behavior in IE8, disable the ConvertToXhtml filter and test again. You should not experience it in IE9, Firefox 10 and WebKit.

    Regards,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Ash
    Ash avatar
    14 posts
    Member since:
    Mar 2012

    Posted 05 Mar 2012 Link to this post

    Thanks so much!!
  4. Ash
    Ash avatar
    14 posts
    Member since:
    Mar 2012

    Posted 07 Mar 2012 Link to this post

    Hi,

    Can you also help me with

    1) How to disable the toolbar's completely? With the below code, an empty toolbar is showing up in the UI.

     

     

    <Tools>

     

     

     

    <telerik:EditorToolGroup>

     

     

     

     

    </telerik:EditorToolGroup>

     

     

     

    </Tools>

     



    2)  I want the radeditor to be the size of a default textbox (width and height).But by setting height (10px) , it is messing up my UI,  the radeditor extends into the below row's in my table. What setting can i make such that my radeditor looks like a textbox.
  5. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 08 Mar 2012 Link to this post

    Hello,

    1) You can hide the toolbar by setting the ToolsFile property to point to an empty ToolsFile.xml file, which contains only <root></root> tags, e.g.
    
    
    <telerik:RadEditor ID="RadEditor1" runat="server" ToolsFile="~/ToolsFile.xml" ></telerik:RadEditor>

    2) The following demo shows how to render RadEditor as a textbox: Displaying RadEditor as a TextBox.

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  6. Ash
    Ash avatar
    14 posts
    Member since:
    Mar 2012

    Posted 16 Mar 2012 Link to this post

    Hi Rumen,

    Thanks for the reply.
    When i click on the radeditor, the toolbox is being shown slightly. PLease check the attachment. Also how do i disable the scrollbars?
  7. Rumen
    Admin
    Rumen avatar
    14351 posts

    Posted 20 Mar 2012 Link to this post

    Hi,

    To hide the toolbar set the ToolbarMode property to Default. To hide the scroller set the CssFiles property to point to some CSS file, which contains the following class:

    body
    {
        overflow: hidden;
    }

    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top