RadDiagram -> Link has a wrong target position of the connection for Gliding connector.

1 Answer 29 Views
Diagram
Bartosz
Top achievements
Rank 1
Iron
Bartosz asked on 13 Jul 2023, 11:25 AM

Hello,

During project implementation a wrong link connection was found.

Precondition:

When we have two models of ContainerNodeViewModelBase OuterModel and InnerModel.

InnerModel has set to true "RadDiagramShapeBase.UseGlidingConnector".

Steps to reproduce:

1. Put InnerModel inside OuterModel.

2. Connect the top middle connector to middle connector of InnerModel

3. When you move InnerModel in upper part of OuterModel the link is connected to bottom of InnerModel instead of to top.

To make reproduce easier i attach video, and i modified your sample application (PasteOnMousePosition) to reproduce this issue.

I attached both things.

Video desc:
1st use case with no gliding connector -- looks ok

2nd use-case movement outside of container and the link looks ok, but the link connection inside looks bad.

Currently this link is just a line, but when it would be an arrow then its looks even worse.

1 Answer, 1 is accepted

Sort by
0
Bartosz
Top achievements
Rank 1
Iron
answered on 13 Jul 2023, 11:30 AM

I have submitted a ticket. This question can be closed.

Ticket url : https://feedback.telerik.com/wpf/1616116-raddiagram-link-has-a-wrong-target-position-of-the-connection-for-gliding-connector

Tags
Diagram
Asked by
Bartosz
Top achievements
Rank 1
Iron
Answers by
Bartosz
Top achievements
Rank 1
Iron
Share this question
or