RadDateTimePicker not behaving as expected after modify its default style

4 posts, 0 answers
  1. Aanchal
    Aanchal avatar
    2 posts
    Member since:
    Sep 2020

    Posted 17 Sep Link to this post

    https://docs.telerik.com/devtools/wpf/controls/raddatetimepicker/styles-and-templates/styling-raddatetimepicker

    After extracting the default style for RadDateTimePicker to the resource file to my application (as mentioned in the above page.), RadDateTimePicker is not working as expected.

    For current month it picks up the correct date that is selected in the calendar. But for previous months and next months, it is picking up different date than selected.

    telerik version- R1 2020

    Attached the screenshot.

     

  2. Vladimir Stoyanov
    Admin
    Vladimir Stoyanov avatar
    686 posts

    Posted 21 Sep Link to this post

    Hello Aanchal,

    Thank you for the shared picture.

    Have you extracted the ControlTemplate from Visual Studio or from the theme XAML File? Sometimes the extraction through Visual Studio fails and grabbing the ControlTemplate from the xaml file is safer. 

    I am attaching a sample project, where I have extracted the ControlTemplate for the RadDateTimePicker for the Fluent theme. Please, check out the shared project, give the above mentioned suggestion a try and let me know how it goes. 

    Regards,
    Vladimir Stoyanov
    Progress Telerik

    Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

  3. Aanchal
    Aanchal avatar
    2 posts
    Member since:
    Sep 2020

    Posted 22 Sep in reply to Vladimir Stoyanov Link to this post

    Hi,

    I am able to use fluent theme in my application but in my telerik folder, I don't have a folder for fluent theme. Can you suggest what I need to do to get it?

    Attaching the screenshot.

  4. Vladimir Stoyanov
    Admin
    Vladimir Stoyanov avatar
    686 posts

    Posted 23 Sep Link to this post

    Hello Aanchal,

    Thanks for the shared picture.

    It seems that you are using a UI for WPF version from 2017, however the Fluent theme was introduced in the R1 2018 release. If you want to use that theme, you can upgrade to the R1 2018 version or to the latest one. Note, that we generally recommend using the latest version as it contains the most features/bug fixes. 

    I hope you find this information helpful. 

    Regards,
    Vladimir Stoyanov
    Progress Telerik

    Five days of Blazor, Angular, React, and Xamarin experts live-coding on twitch.tv/CodeItLive, special prizes, and more, for FREE?! Register now for DevReach 2.0(20).

Back to Top