RadDatePicker Today's style apply only on mouse over

8 posts, 0 answers
  1. guillaume.lebel
    guillaume.lebel avatar
    60 posts
    Member since:
    Oct 2012

    Posted 18 Nov 2008 Link to this post

    I've been trying to set a style on today's date, but the style isn't applying until I have mouse over the date.

    Here is the code i'm using to apply the style:

      <calendar ShowRowHeaders="false">
        <SpecialDays>
          <telerik:RadCalendarDay Repeatable="Today" Date="" IsToday="true">
            <ItemStyle BackColor="#eafd9e" />
          </telerik:RadCalendarDay>
         </SpecialDays>
      </calendar>

    I'm using asp.net 2.0 with vs 2005.

    My current version of telerik is : 2008.1.512.20 - v2.0.50727

    Thank you and have a nice day.



  2. Dimo
    Admin
    Dimo avatar
    8456 posts

    Posted 19 Nov 2008 Link to this post

    Hi Guillaume,

    Which skin are you using for the calendar?


    Best wishes,
    Dimo
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. guillaume.lebel
    guillaume.lebel avatar
    60 posts
    Member since:
    Oct 2012

    Posted 19 Nov 2008 Link to this post

    Hi,

    For my datePicker i'm using my own skin but i've compare with the css to see if i had all the class for each element and nothing is missing. I've set EnableEmbeddedSkins to false.

    Thank you!
  4. guillaume.lebel
    guillaume.lebel avatar
    60 posts
    Member since:
    Oct 2012

    Posted 20 Nov 2008 Link to this post

    Hi,

    I've tried change my skin and apply one of the telerik skin but i still have the same problem. The today's date isn't showing correctly.
  5. Dimo
    Admin
    Dimo avatar
    8456 posts

    Posted 20 Nov 2008 Link to this post

    Hello Guillaume,

    Some skins do not support declarative customization of the cell's background color, because the skin uses background images and they take precedence over background colors.

    I will have to ask you to send your custom skin, but an easier solution for you will be to use the following CSS rules:


    .RadCalendar_SkinName  .rcMainTable  .rcToday
    {
          background:none #eafd9e;
    }
    .RadCalendar_SkinName  .rcMainTable  .rcToday  a
    {
          background:none transparent;
    }


    If you still have problems, then please send your custom skin.


    Regards,
    Dimo
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  6. Caesar
    Caesar avatar
    59 posts
    Member since:
    Aug 2008

    Posted 11 Feb 2010 Link to this post

    Hello!

    This problem still exists in version 2009.3.1314.
    I'm using the default telerik skin.



    The problem seems to be that the class rcToday is removed by some telerik-script when hover/selected, and then applied again on mouseout/deselected.

    /Rikard
  7. Dimo
    Admin
    Dimo avatar
    8456 posts

    Posted 11 Feb 2010 Link to this post

    Hi Caesar,

    That's right - the "normal" state CSS class is always replaced by the "hover" or "selected" state CSS class.


    Dimo
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  8. Phil
    Phil avatar
    2 posts
    Member since:
    Jun 2011

    Posted 20 Aug 2011 Link to this post

    I think I am having the same (or very similar) problem, and I am still not sure what solution you are suggesting. 

    I load my calendar with a date programmatically selected.  If I click on any other date on the calendar, that date will show selected, but the date that was programmatically selected when the calendar was loaded will also display as selected.  This behavior continues until I mouse-over the date that was programmatically selected.  After that, dates appropriately display as selected or not selected.

    I am using the Web20 skin.

    Thanks.


    Disregard.. Setting AutoPostBack to TRUE resolves this.
Back to Top