RadControls_WinForms_2009_1_311_dev: can't register toolbox items

4 posts, 0 answers
  1. Alexey
    Alexey avatar
    9 posts
    Member since:
    Aug 2008

    Posted 30 Mar 2009 Link to this post

    Hello!

    I've just installed RadControls_WinForms_2009_1_311_dev width Visual Studio 2008 service pack 1. I had RadControls_for_ASP.NET_AJAX_2009_1_311_dev and haven't ever had installed any WinForms radcontrols. Also, there is installed Visual Studio 2005.

    During installation of RadControls_WinForms_2009_1_311 I unchecked support for VS 2005 and left VS 2008 only. At the end of installation there was and error box reporting that ToolBox failed. After that, I didn't find RadControls in VS 2008's toolbox.

    How could I add RadControls_WinForms into VS 2008 toolbox manually? The only installed third party controls are DevExpress for WinForms. Maybe, they are conflicting?

    With best regards,
    Alexey
  2. Vassil Petev
    Admin
    Vassil Petev avatar
    1765 posts

    Posted 30 Mar 2009 Link to this post

    Hi Alexey,

    We will be glad to help you with this question. Before doing so, however, please ask the purchase holder in your company who purchased our controls to add you as a License Developer to the purchase. More information on License Developers you can find here: http://www.telerik.com/account/faqs.aspx. Doing this will give you full access to our support ticketing system and will unlock some of the support resources we offer.

    Please, let us know once this is done and we will send you information on how to add the tools manually in the toolbox.


    All the best,
    Vassil
    the Telerik team

    Check out Telerik Trainer , the state of the art learning tool for Telerik products.
  3. Gary
    Gary avatar
    6 posts
    Member since:
    Oct 2008

    Posted 12 Apr 2009 Link to this post

    Alexey,

    I too am having the same problem. Installing latest Telerik version. Running on Vista X64 Ultimate. Shows up in the VS2005 but not the VS2008. Also had this problem on my old box running WinXP.
    I certainly do not agree with your time table to resolve this issue. 2009.2 will be out sometime in June or July I'm guessing mean while when ever we install a hotfix or in my case have to reinstall the controls , I have to deal with this. I feel this is a major issue and should be resolved ASAP.

    Thanks,
    Gary
  4. Jordan
    Admin
    Jordan avatar
    547 posts

    Posted 14 Apr 2009 Link to this post

    Hello Gary,

    Indeed our current toolbox installer does not work well in all cases. We are sorry for the inconvenience.

    We are currently working on a new way to install RadControls for WinForms components in Visual Studio toolbox. We will use this new toolbox installer as soon as it is ready and tested. Unfortunately I cannot give you any specific time frame currently, but it will most probably be included in Q2 2009 release.

    For the time being, you can manually add the controls in the Visual Studio toolbox by following the steps in this KB article:
    http://www.telerik.com/support/kb/winforms/general/add-radcontrols-for-winforms-to-the-toolbox.aspx

    Regards,
    Jordan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
Back to Top