This is a migrated thread and some comments may be shown as answers.

RadComboBox in an EditItemTemplate

3 Answers 52 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Fred
Top achievements
Rank 1
Fred asked on 14 Nov 2008, 05:13 PM
I have a quick question regarding using a radcombobox inside the edit template in a radgrid.  I've read other questions on the fourms here but they don't seem to apply to what I have going on.  My combo box binds properly and seems to work fine, the only problem is the drop down list seems to be rendered under the radgrid.  I am using  a tabstrip and a multipage but if I put the controls(combobox inside edit template of radgrid) on their own page the same thing happens so I assume those 2 containers have nothing to do with the problem.  Is there a property of either of these controls that I am missing or something I forgot to do force the dropdown animation to display above the radgrid so that I can see and interact with it rather than undreneath.

P.S.  I have tried to play with the z-index to no avail.

Thanks.
 
Edit:  Spelling.

3 Answers, 1 is accepted

Sort by
0
Yavor
Telerik team
answered on 18 Nov 2008, 07:26 AM
Hello Fred,

This indeed seems like a styling issue of the implementation. If the issue persists, you can open a formal support ticket, and send us a small working project, demonstrating the setup, as well as the unwanted behavior. We will review it locally, and get back to you with additional information.

Sincerely yours,
Yavor
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Fred
Top achievements
Rank 1
answered on 18 Nov 2008, 02:45 PM
I worked around the problem using multiple aspx pages inside a Radsplitter and Radpane rather than using a multipage.  This project is pretty time sensitive so I don't have time to work through exactly what is going on here yet but when I get some free cycles I'll get back to figuring it it out.

Thanks for the response.
0
Yavor
Telerik team
answered on 21 Nov 2008, 08:46 AM
Hello Fred,

I am glad that the issue is worked-around for the time being.
When you have the time, you can open a formal support ticket, and send us the problematic code.

Best wishes,
Yavor
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
Fred
Top achievements
Rank 1
Answers by
Yavor
Telerik team
Fred
Top achievements
Rank 1
Share this question
or