RadComboBox Google Chrome only ZIndex issue

3 posts, 0 answers
  1. Joe
    Joe avatar
    49 posts
    Member since:
    May 2008

    Posted 31 Aug 2011 Link to this post

    Hello, please see the following page for our issue:

    http://www.humaliensacademy.com/market/

    - You will be redirected to login screen, login with:
    username:  joeTester
    password:  joeTester1

    Once logged in, go back to the link above.

    - ISSUE:  click on the SELECT SET combobox in Google Chrome.  You will see it appears behind the Silverlight PivotViewer below it.  This only happens in Google Chrome.  I've tried all the Z-Index fixes from all the other threads, no luck, and if you view the source you will see I have the Z-Index set very high on the combobox and its surrounding div.  Is there a way to set the Z-index on the actual pop out specifically or something?    Please help.  thank you.

    - SIDE QUESTION:  Notice I changed the background color of the combobox to that green to match the screen.  How do I change the background color of the pull down image part?  you will see it is still the default white color.  Thanks again.

    joe
  2. Ivana
    Admin
    Ivana avatar
    657 posts

    Posted 05 Sep 2011 Link to this post

    Hi Joe,

    Regarding the overflow problem of the RadComboBox over the Silverlight object in Google Chrome, please refer to the following forum thread:
    Telerik combo box drop down not showing over Silverlight object in Google Chrome.

    I'm not quite sure about your second question, but you could try to style the
    .RadComboBox .rcbReadOnly .rcbInput classes in order to set the desired color.

    Hope that helps.

    Greetings,
    Ivana
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  3. Joe
    Joe avatar
    49 posts
    Member since:
    May 2008

    Posted 08 Sep 2011 Link to this post

    Thank you for the reply.  I tried that solution a while back.  it technically works as the drop down appears over the silverlight object.  But setting that property on the Silverlight PivotViewer causes the pivotviewer to not work.  So this is not an issue on your end anymore, hopefully pivotviewer 2 that just came out will fix this issue.
Back to Top