This is a migrated thread and some comments may be shown as answers.

Rad StyleSheet Manager - WebResource css file not working when embed inside a folder

3 Answers 155 Views
ScriptManager and StyleSheetManager
This is a migrated thread and some comments may be shown as answers.
Meenakshi Nagalingam
Top achievements
Rank 1
Meenakshi Nagalingam asked on 21 Aug 2009, 10:44 AM
Hi,

I've tried out creating new skins using RadStyleSheetManager by following the url:


It was working fine as i followed the url.

Later i wanted to restructure the folders available in my project based on the skin names. So i moved all the files to a separate folder TelerikSkins and moved all the images, cs file into that. But when i moved the css file in to that folder and modified the webresource as in the code snippet below, the stylesheet is not applied in the web page!

using System; 
using System.Collections.Generic; 
using System.Linq; 
using System.Text; 
using System.Web.UI; 
 
[assembly: WebResource("TelerikCustomSkins.TelerikSkins.TelerikSkinForComboBox.css""text/css")] 
namespace TelerikCustomSkins 
   public class TelerikSkin 
   { 
   } 

But when it is in the root folder of the project, it is working fine. Otherwise nothing happend!

Please let me know how to mark a css file as Web Embedded resource when it is inside a folder.

Thanks

3 Answers, 1 is accepted

Sort by
0
Veselin Vasilev
Telerik team
answered on 24 Aug 2009, 08:16 AM
Hi Meenakshi Nagalingam,

Please find attached a sample project. Look at the Default2.aspx page and the
ClassLibraryProject \ TelerikCustomSkins2 class library project.

The CSS file is under the Vista folder and the images are under Vista \ Images folder.

I hope this helps.

Best wishes,
Veselin Vasilev
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Subhrajyoti
Top achievements
Rank 1
answered on 23 Aug 2010, 08:35 AM

i have got a problem when i run this demo sample loke

"Object reference not set to an instance of an object."

0
Stuart Wachsberg
Top achievements
Rank 1
answered on 27 Aug 2010, 03:06 PM
Me too.
I have got same problem
Telerik.Web.UI_2010_2_826, VS2010
Tags
ScriptManager and StyleSheetManager
Asked by
Meenakshi Nagalingam
Top achievements
Rank 1
Answers by
Veselin Vasilev
Telerik team
Subhrajyoti
Top achievements
Rank 1
Stuart Wachsberg
Top achievements
Rank 1
Share this question
or