This is a migrated thread and some comments may be shown as answers.

question about datasource

2 Answers 42 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Robert Strazzarino
Top achievements
Rank 1
Robert Strazzarino asked on 23 Jun 2010, 09:08 PM
I have a report that has only a table in the detail section.  I found that if have a datasource added to the report and  also the same datasource assigned to the table then the report data has the data repeated -  First black of data then the same block repeated.  If I remove the datasource for the report then the data is only shown once.
Why is this happening?
Thanks,
Robert

2 Answers, 1 is accepted

Sort by
0
Robert Strazzarino
Top achievements
Rank 1
answered on 26 Jun 2010, 07:45 PM
This shows as having a reply but there is only one entry.  I really would like to know what the issue is.

Thanks,
Robert
0
Accepted
Peter
Telerik team
answered on 28 Jun 2010, 03:02 PM
Hello Robert Strazzarino,

This is the expected behavior. If you set the Report's DataSource property, the detail section displays at run-time one row for each detail item in the report data source. On the other side the Table report item is a separate data region and does not make use of the report's data source, but if placed in the detail section, would be repeated like any other item.

Greetings,
Peter
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
General Discussions
Asked by
Robert Strazzarino
Top achievements
Rank 1
Answers by
Robert Strazzarino
Top achievements
Rank 1
Peter
Telerik team
Share this question
or