Q3 2008 SP2 Breaking Progress

Thread is closed for posting
5 posts, 0 answers
  1. jenkmeister
    jenkmeister avatar
    19 posts
    Member since:
    Mar 2007

    Posted 21 Jan 2009 Link to this post

    I've upgraded from Q2 2008 to the Q3 SP2 bits, and now the progress area is no longer being displayed (worked with no issues in Q2).

    Tracing the web requests, I can see calls being made to the Telerik.RadUploadProgressHandler.ashx but the content returned is always:

    var rawProgressData = {InProgress:false,ProgressCounters:false};

    The OnClientProgressUpdating event also appears to no longer be called (which I'd assume is because the progress data is reporting the upload isn't in progress). The OnClientProgressStarted event however is being called. The file also completes it's upload.

    I've been through the troubleshooting guides which unfortunately have not resolved the issue.

    Telerik - please help... (this is the 3rd major breaking issue I've come across in the SP2 update which is starting to make me consider rolling back to the Q2 bits)
  2. Veselin Vasilev
    Admin
    Veselin Vasilev avatar
    2992 posts

    Posted 22 Jan 2009 Link to this post

    Hi jenkmeister,

    This is indeed strange. It is working fine on our online demos.
    You can also check the Changes and backward compatibility page.

    Can you isolate the problem in a small running project and send it to us in a new support ticket?

    Regards,
    Veselin Vasilev
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. Christopher Bishop
    Christopher Bishop avatar
    50 posts
    Member since:
    May 2008

    Posted 26 Jan 2009 Link to this post

    Same problem, online demos work fine as a matter of fact i just took the code from here:
    http://demos.telerik.com/aspnet-ajax/Upload/Examples/UsingTargetFolder/DefaultCS.aspx

    And it works fine locally VS2008, but copy it to the Win 2003 web server and nada the file uploads just fine but the progress "never" shows, even if you do a js.style.display=''; on it to force it to be seen it is never updated.
  4. jenkmeister
    jenkmeister avatar
    19 posts
    Member since:
    Mar 2007

    Posted 27 Jan 2009 Link to this post

    I spent about a day doing more investigation, starting with a brand new web site and then working that back into the site it wasn't working on. Eventually I got the progress working again. It turned out that in my global.asax, there was an override for the Application_BeginRequest function. The code in that function was left over from an issue with flash and cookies from using a different upload control before using this telerik one. Once I removed that code, the progress worked again. This was on a Win2K3 box.

    Christopher - if you can get Httpwatch or Fiddler setup, see what content is coming back when the request handler responds. If you're getting a response that is what I was seeing (the var rawProgressData...), then your handler is setup. Next see if there are any other httpmodules in the web config. Then check the global.asax. That seems to be the list I had to go through.
  5. Yuriy Rogach
    Yuriy Rogach avatar
    6 posts
    Member since:
    Feb 2008

    Posted 04 Feb 2009 Link to this post

    Hi jenkmeister,

    I have the same problem, but can't find the way how to fix it.

    I have several custom HttpHandlers, but it's registered below then "Telerik.RadUploadProgressHandler.ashx".

    Evething was working fine in Q2 2008, but after installing Q3 SP2 the progress area is no longer being displayed.

    I'm getting the same as you from RadUploadProgressHandler.ashx - var rawProgressData = {InProgress:false,ProgressCounters:false};

    I'm using IIS 7.0

    Any idea ?
Back to Top