This is a migrated thread and some comments may be shown as answers.

Q2 display issue when using ShowOnFocus

6 Answers 111 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Michael
Top achievements
Rank 1
Michael asked on 28 Jul 2008, 07:06 PM
Telerik,

I have a RadEditor that is using ToolbarMode="ShowOnFocus".  After upgrading to the Q2 release, the RadEditor no longer displays properly when first displayed.

I am using the RadEditor control in a custom DotNetNuke module.  When it first opens up, the RadEditor has a large unusable section at the top, and the actual content editor section is only a row or two high at the bottom.  Once you place the cursor in the content area as if you were ready to type, the content area grows to fill the entire area (which is how it should look initially) and the toolbar appears above the grid as expected.  So, it is the initial display of the RadEditor that is not working correctly.  Once you have placed your cursor in the content area, everything is great.  I am not sure if this is an issue with IE quirks mode or what.

Please advise on a fix.

Thanks!

Michael

6 Answers, 1 is accepted

Sort by
0
Tom
Top achievements
Rank 1
answered on 29 Jul 2008, 03:28 PM
I am havnig this same issue with the RadEditor in RadControls for ASP.NET Ajax Q2 2008 used in an ASP.Net web application.

Additionally for me, after you give the editor focus (by clicking in the editor window for example) the toolbar displays in the correct spot only when the entire page fits on screen without scrollbars. If the page is too long and there are scroll bars, the toolbar shows up in the wrong spot. The problem seems to get worse if you scroll down and then give the editor focus again. It looks like the toolbars reappear in their original position relative to the frame, not at the top of the editors. The issue might be caused by the fact that the page is getting loaded in a frame, but I haven't done enough testing to state that as a fact.
0
Accepted
Obi-Wan Kenobi
Top achievements
Rank 1
answered on 30 Jul 2008, 11:51 AM
I tried the following online example, which is with 5 editors with ShowOnFocus toolbars: 
http://www.telerik.com/DEMOS/ASPNET/Prometheus/Editor/Examples/ToolProvider/DefaultCS.aspx
I tried it with IE7 and FF3 and everything seems to be ok.
As far as I know asp.net ajax framework should be used with xhtml doctype. I looked at the example source and noticed that its doctype is:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
Hope this helps!
0
Tom
Top achievements
Rank 1
answered on 30 Jul 2008, 10:50 PM
That was the problem. The pages that this problem is happening are the oldest in our system. The doctype was set to: 

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">

Once we changed it, the editor rendered correctly. Now to fix the compliance issue and we're good.
0
Michael
Top achievements
Rank 1
answered on 04 Aug 2008, 06:09 PM
Unfortunately, I do not think it is possible to change this setting from within DotNetNuke.  If someone knows how, please let me know.  Otherwise, can someone from Telerik please chime in here with a solution?

Thanks!

Michael
0
Accepted
Lini
Telerik team
answered on 05 Aug 2008, 07:21 AM
Hello,

DotNetNuke has its own skinning mechanism, which allows you to customize the look and feel of the page. Starting with version 4.4, the skinning mechanism also allows you to set the DOCTYPE of the page by creating a special XML file in your skin folder. The steps are described in the following blog post: http://www.dotnetnuke.com/Community/BlogsDotNetNuke/tabid/825/EntryID/1226/Default.aspx

The issue with RadEditor is probably caused by the fact that we changed the default DNN skin from Default2006 to Telerik in the Q2 2008 release. This is because the Default2006 skin is being phased out and we had to replace it with a different one. If you do not want to change the skin DOCTYPE, you can try changing the editor skin - the setting should be located in the editor configuration file at ~/DesktopModules/TelerikWebUI/RadEditorProvider/ConfigFile.xml in the DNN web site.

We will investigate this further and see if we can fix it in the next RadEditor provider release.

Regards,
Lini
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Michael
Top achievements
Rank 1
answered on 06 Aug 2008, 01:47 AM
Thank you very much for the link to that article!  We implemented this immediately.

Thanks!

Michael
Tags
Editor
Asked by
Michael
Top achievements
Rank 1
Answers by
Tom
Top achievements
Rank 1
Obi-Wan Kenobi
Top achievements
Rank 1
Michael
Top achievements
Rank 1
Lini
Telerik team
Share this question
or