This is a migrated thread and some comments may be shown as answers.

publishing

3 Answers 25 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
ehsan
Top achievements
Rank 1
ehsan asked on 03 Oct 2008, 04:55 AM
hi telerik
i'm using (iis 5.1 with q1 ajax + aspnet 3.5)
all things in my computer is true,
but...
i published my project to another pc's iis, 
then when i open pages in browser all rad components will display as links...

i tested that pc by installing vs2008 and adding telerik components...
in design time components shown correctly but when i build my project
i see components uncorrectly (menus,panels,...)
i think scripts dosnt function correctly...
what is deference between my computer configuration and second one?
and how can i fix this problem.

i tested this :
1- clean install of winxp sp3 + all aditional componets
2- install framework 3.5
3- vs2008 team suite
4- open new asp.net project
5- adding telerik.ui.web... to toolbar and refrences
6- inserting some telerik components on my web page with script manager...
7- build and run...
but probelm exist in output! no visual elements ! all is as links
8- i am confused!
tnx

3 Answers, 1 is accepted

Sort by
0
Todd Anglin
Top achievements
Rank 2
answered on 06 Oct 2008, 06:28 PM
E-

It sounds like a problem with CSS or JavaScript (or both) not being correctly rendered on your page, and the most likely cause is permissions on your new box. Try using something like Fiddler or Firebug (for Firefox) to inspect your page and see what's being rendered. Also inspect the net traffic and look for any errors. I expect you'll find a number of your requests are either A) being blocked (access denied), or B) getting 404s for some reason.

Also, make sure you new ASP.NET project is targeting .NET 3.5, that you have a ASP.NET ScriptManager on the page, and that the web.config is properly configured to supply the required ASP.NET AJAX resoruces.

If you can provide more details about JavaScript and net traffic errors you're seeing on the page, I'll try to provide more input.

-Todd
0
ehsan
Top achievements
Rank 1
answered on 08 Oct 2008, 05:34 AM
hi ted ,
thank u about ur reply,
but my problem not solved yet,

1- i installed winxpsp3+vs2008 only,
2- installed asp.net ajax q2
3- when i open telerik samples controls like (menu,tabstrip) shown as links...
4- when i open new project with ms update panel ... my ajax project works correctly, but problem is about rad controls,
for exampl when i add menu , in design time i can see it correctly,
but when i run my project it shown as links...

i am searchin from 2 weeks to now!!
plz help

0
ehsan
Top achievements
Rank 1
answered on 02 Nov 2008, 09:53 AM
hi folks,
solved!

GACUTIL -I <dllname>

that solved my problem in 2 week hard working.

Tags
General Discussions
Asked by
ehsan
Top achievements
Rank 1
Answers by
Todd Anglin
Top achievements
Rank 2
ehsan
Top achievements
Rank 1
Share this question
or