This is a migrated thread and some comments may be shown as answers.

Problem with height when enabled = false

6 Answers 141 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Darren166
Top achievements
Rank 1
Darren166 asked on 06 Mar 2008, 02:31 AM
Hi,

I had a problem with the fact that the height was set at 400px when radeditor was disabled via enabled = false.  I read a workaround in this thread http://www.telerik.com/community/forums/thread/b311D-bagbee.aspx which suggested using

if (radEditor.Enabled == false)  
        radEditor.ControlStyle.Reset();

in the code behind.  This worked great and cleared the height from the div if the editor was disabled.  However I just installed a hotfix 2007.3.1428 that I was issued to solve a different problem and now the above no longer works.

Can you please help

Darren.

6 Answers, 1 is accepted

Sort by
0
George
Telerik team
answered on 07 Mar 2008, 05:18 PM
Hi Darren,

Indeed, the "radEditor.ControlStyle.Reset()" was working in the previous versions of RadEditor "Prometheus".  We found however, some problems in the previous Height implementation and changed it. Now, there is no need of the "radEditor.ControlStyle.Reset()" because, you can set the height directly.




Best regards,
George
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
John
Top achievements
Rank 2
answered on 24 Apr 2008, 07:44 AM
I have set the AutoResizeHeight to true, but it only works well with Edit mode, with readonly mode it still shows a certain height even there is no content, although I didn't specify any height in the control.

Kindly help further as I was using the ControlStyle.Reset() too to resize for enabled=false before, but it is not working now.

Thanks -- Bidan
0
George
Telerik team
answered on 25 Apr 2008, 01:31 PM
Hi Bidan,

Could you please open a support ticket and send us your runnable project, or a sample one in which the problem can be observed, along with a detailed description of the problem? Once we are able to reproduce the problem on our side we will do our best to provide a solution.


Sincerely,
George
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Rob Heckart
Top achievements
Rank 1
answered on 22 May 2008, 07:09 PM
Could someone give me an update on this? I'm having the same problem, just downloaded 515.35 and set AutoResizeHeight="true". Still generates a div like this:

<div id="ctl00_cphMain_edtCart" style="width:100%;height:400px;background-color:White;width:100%;"

Don't want it locked at 400px height. Should be auto or something.

Thanks!

0
George
Telerik team
answered on 26 May 2008, 01:43 PM
Hi Rob,

You can use the following approach to achieve the desired behavior:
Please set style="height:100%" attribute inline into the editor's declaration - the style tag will be applied to the editor's content when it is in non-editable mode.
<telerik:RadEditor style="height:100%" Height="400" ID="RadEditor1" runat="server" Enabled="false" AutoResizeHeight="true">  
    <Content> 
    First line  
    <br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /><br /> 
    Last line  
    </Content>     
</telerik:RadEditor>  

I hope this helps.

Sincerely,
George
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Rob Heckart
Top achievements
Rank 1
answered on 30 May 2008, 01:19 PM
That solved the problem! Thanks!
Tags
Editor
Asked by
Darren166
Top achievements
Rank 1
Answers by
George
Telerik team
John
Top achievements
Rank 2
Rob Heckart
Top achievements
Rank 1
Share this question
or