This is a migrated thread and some comments may be shown as answers.
Problem with
5 Answers 43 Views
This is a migrated thread and some comments may be shown as answers.
veera
Top achievements
Rank 1
veera asked on 08 Oct 2012, 04:23 PM
Hi Team,

I am using Rad-combo (V 2009.1.527.20) and facing issue .
Is it fixed with new versions? Please send me a sample if any workaround for this.
(Images attached )

My Page with Rad Combo:

Properties set:  AllowCustomText = True , EnableTextSelection = True and MarkFirstMatch = True

When the first letter typed matches an available title in the dropdown, the title is populated.

The problem is that when you continue typing, even if the next characters match the first or another entry, the characters are appended to the front of the populated title making the entry entirely unintended and preventing freeform entry.  Normal expected behavior would be for the automatically suggested selection to go away and accept the user entered characters if the remaining entries do not match. 


5 Answers, 1 is accepted

Sort by
0
Nencho
Telerik team
answered on 09 Oct 2012, 03:45 PM
Hi Veera,

I have performed some tests, but unfortunately I could not replicate the experienced problem. Please see below a video demonstrating the behavior at my end. Could you provide us a snippet of code regarding the usage of the RadComboBox. In addition, a video demonstrating the problematic behavior at your end will be great appreciated.

Regards,
Nencho
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
veera
Top achievements
Rank 1
answered on 10 Oct 2012, 07:05 AM
Hi Nencho,

I am using Telerik.Web.UI.dll version is 2009.1.527.20 and my browser is IE7.

updated sample proj @ http://www.screencast.com/t/p20p7ud9MtqZ

Also i have captured Combo behavior in my actual application : http://www.screencast.com/t/aSWrC9ErbPI


Thanks,
Veera
0
Nencho
Telerik team
answered on 11 Oct 2012, 03:58 PM
Hi Veera,

We are aware of that problem and it is fixed in version newer than 2009.3.1314, so please consider to update if possible. If you could not perform the update, you could refer to our forum thread, where a workaround for the issue is provided.

Kind regards,
Nencho
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
veera
Top achievements
Rank 1
answered on 12 Oct 2012, 08:57 AM
Hi Nencho,

Thanks for update.

Please clarify two things.

1) we have not taken any update after V 2009.1.527.20.If we upgrade our system with new Version any issues will come up?
  i Mean any functionality is obsolete  w.r.to old version?
2) We are using fewer set of Rad controls.any patch will work to update only that set of controls? 


Thanks 
Veera
0
Nencho
Telerik team
answered on 15 Oct 2012, 02:56 PM
Hello Veera,

Since the old version of the controls that you use in your project, there might be some breaking changes in the new version all of which are listed in the release notes of every single release.

As for your second question, you could not update to only a certain set of control. One thing I can suggest is to download the trial version of the used controls and implement them in your project.

If there are any discrepancies related to the upgrade please feel free to get back to us.

Kind regards,
Nencho
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Asked by
veera
Top achievements
Rank 1
Answers by
Nencho
Telerik team
veera
Top achievements
Rank 1
Share this question
or