This is a migrated thread and some comments may be shown as answers.

Problem in setting up Telerik Control - IIS 7/VISTA Environment

1 Answer 72 Views
This is a migrated thread and some comments may be shown as answers.
Top achievements
Rank 1
Abinash asked on 07 Nov 2008, 03:37 AM
Recently we have migrated our project from ASP.Net 1.1 Web Application  to .Net 2.0 Web Application.
We are trying to use a telerik Rad Combobox in our application for AJAX implementation. We currently have two kinds of development environments.
  • Windows 2000, Visual Studio 2005, IIS 5.0.
  • Windows VISTA,Visual Studio 2005, IIS 7.0.
When we set up the teleric in the IIS 5.0 environment, it works perfectly fine, but we are not able to set the application in IIS 7.0. Following error is coming while implementing the same:
'~/Telerik.Web.UI.WebResource.axd' is missing in web.config. RadScriptManager requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information: Controls > RadScriptManager
We have refered to lots of sites and made the config file changes. Below is the setup.
  <validation validateIntegratedModeConfiguration="false">
   <add name="WebResourceHandler" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI" />
        <httpRedirect enabled="false" destination="" exactDestination="true" childOnly="true" />
We have also tried entering the Version Number in the type field but the same error persists. We have used smart tag to add handler automatically and then change httpHandler it to Handler but not able to resolve the issue.
Could you please help us in this.
Appreciate if you could share us all the steps to be followed for  Windows VISTA,Visual Studio 2005, IIS 7.0 environment.

1 Answer, 1 is accepted

Sort by
Atanas Korchev
Telerik team
answered on 07 Nov 2008, 08:14 AM
Hello Abinash,

Try leaving the registration of the http handler in the <system.web><httpHandlers> section as well in the <system.webServer><handlers>. Unfortunately At the time being RadScriptManager checks always in the <system.web><httpHandlers>. Alternatively you can set the EnableHandlerDetection property to false.

the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Asked by
Top achievements
Rank 1
Answers by
Atanas Korchev
Telerik team
Share this question