PivotGrid export to excel gibberish

2 posts, 0 answers
  1. John
    John avatar
    5 posts
    Member since:
    Sep 2007

    Posted 01 Jun Link to this post

    I have a pivot grid bound to a sql data source. When I attempt to export, the resulting excel file is gibberish (see screenshot). My version is 2017.1.118. What am I missing?

        <telerik:RadPivotGrid ID="rpgResults" runat="server" DataSourceID="sdsSummary" Width="100%"
            EnableTheming="false" EnableEmbeddedSkins="true" Skin="Default" RenderMode="Lightweight"
            AllowFiltering="False" AggregatesPosition="Columns" ShowFilterHeaderZone="False" ShowDataHeaderZone="False" ShowColumnHeaderZone="False" ShowRowHeaderZone="False"
            OnCellDataBound="RadPivotGrid1_CellDataBound"> 
            <ClientSettings>
                <Scrolling AllowVerticalScroll="True" ScrollHeight="600px" />
            </ClientSettings>
            <Fields>
                <telerik:PivotGridRowField DataField="Year" />
                <telerik:PivotGridRowField DataField="Qtr" />
                <telerik:PivotGridRowField DataField="Month" SortOrder="None" />
                <telerik:PivotGridColumnField DataField="InvoiceType" />
                <telerik:PivotGridAggregateField  DataField="Amount" Aggregate="Sum" DataFormatString="{0:C}" />
                <telerik:PivotGridAggregateField DataField="Invoices" Aggregate="Count" DataFormatString="{0:N0}" />
            </Fields>
        </telerik:RadPivotGrid>

    button click code for exporting...

            rpgResults.ExportSettings.Excel.Format = PivotGridExcelFormat.Biff
            rpgResults.ExportSettings.FileName = "Processed_Invoice_Summary"
            rpgResults.ExportSettings.IgnorePaging = True
            rpgResults.ExportSettings.OpenInNewWindow = False
            rpgResults.ExportToExcel()

  2. John
    John avatar
    5 posts
    Member since:
    Sep 2007

    Posted 05 Jun in reply to John Link to this post

    I solved this in case anyone else has the same issue. I had some site-wide content-encoding added for compression. Once I disabled it for my page in question, the export worked.
Back to Top