Page size in ReportViewer different

7 posts, 0 answers
  1. Lucien
    Lucien avatar
    7 posts
    Member since:
    Aug 2010

    Posted 30 Mar 2011 Link to this post

    Hi all,

    My application includes a Telerik report for a client that has a printer with A3 printing capability. I have defined the PaperKind to A3, Landscape to False, and the Width to 42cm. The PaperSize (disabled in the Properties list) shows a correct 297mm x 420mm. In design mode everthing looks fine and I can add controls over the required width of the report.

    However, when running the report in the WinForms ReportViewer the report splits my pages, spreading the columns over 2 pages. I suspect this is due to the fact that my default printer (attached to my development machine) does not support A3 printing.

    Is this a correct assumption?
    Can I change this setting so I can see the report on screen in A3 width?

    Lucien Dol
    QicSoluciens
    Wellington, New Zealand

    (Telerik Reporting Q1 2011 v5.0.11.316)
  2. Lucien
    Lucien avatar
    7 posts
    Member since:
    Aug 2010

    Posted 04 Apr 2011 Link to this post

    *Bump*

    Does anybody have an answer to my question, please? Thanks!

    Lucien.
  3. Lucien
    Lucien avatar
    7 posts
    Member since:
    Aug 2010

    Posted 04 Apr 2011 Link to this post

    Hmmmm..

    I have now solved this by setting the PageSettings on my report again (to the A3-related values) just before the RefreshReport() command. Looks great now. :-)

    Lucien.
  4. Pizza
    Pizza avatar
    7 posts
    Member since:
    Feb 2013

    Posted 25 Apr 2018 Link to this post

    Hi

    I am experiencing a problem with ReportViewer on Windows 10. When the user has customized scaling of more than 100%, the report does not render correctly(see attached image). We updated to the latest version (Telerik Reporting R1 2018 SP2 (version 12.0.18.227)) and the issue still there. I am not sure how to fix this issue. Any help?
  5. Nasko
    Admin
    Nasko avatar
    1050 posts

    Posted 30 Apr 2018 Link to this post

    Hi Pizza,

    The mentioned attached image is missing for some reason. The allowed attachment extensions are gif, .jpg, .jpeg, .png.

    Regards,
    Nasko
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Pizza
    Pizza avatar
    7 posts
    Member since:
    Feb 2013

    Posted 30 Apr 2018 in reply to Nasko Link to this post

    Nasko, pleasesee attached.
  7. Silviya
    Admin
    Silviya avatar
    354 posts

    Posted 03 May 2018 Link to this post

    Hi Pizza,

    Firstly, my assumption is that you have a WinForms application which is using the Windows Forms Report Viewer.

    I experimented with our demo reports and indeed, when using DPI Unaware application to preview the report, it is rendered with smaller size and remained space on the right and this is an expected behavior.

    When using Windows Forms ReportViewer on a machine with DPI scale factor higher than 96 (100%), Windows will stretch the application bitmap to the expected physical size, although this results in the application being blurry. This is because the application in which you are using the Windows Forms Report Viewer is not declared as DPI aware.

    However, the recommended approach is setting dpiAware element in your application to avoid further scaling, visual or interaction issues. You might check our demos located in product installation path, i.e. C:\Program Files (x86)\Progress\Telerik Reporting <VERSION>\Examples\CSharp|VB\WinFormsDemo. Note the dpiAware.manifest file at the root of the application.

    Regards,
    Silviya
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top