Object reference not set to an instance of an object while using same parameter for all SQL DataSource

2 posts, 0 answers
  1. Software
    Software avatar
    11 posts
    Member since:
    Mar 2017

    Posted 18 Dec 2017 Link to this post

    Hi all, I have 2 SQL DataSources for my Telerik reporting. In coming time may be I need more than 10 SQL DataSource. Each SQL DataSource is applied for different table and each SQL DataSource refer different table in Database. The common thing between two tables is Parameter (that is "Product Code") and it will remain common for all SQL DataSources even in Future. 

    I can able to successfully make the connection with database and when I run query in SQL DataSource it is giving me output but when I try to get same output in Table Wizard then I get an error: "Object reference not set to an instance of an object". Let me tell you I used same parameter for already existing two tables and I am trying to use it for third table, that time I am getting this error.
    Can you please help?? Thank You

  2. Todor
    Admin
    Todor avatar
    397 posts

    Posted 21 Dec 2017 Link to this post

    Hello,

    The provided information is not sufficient to identify what exactly is causing "Object reference not set to an instance of an object" error in the report.

    How do you use the parameter - for filtering on the data source level, or on the report item level (Table), or in some other way? Generally, the report parameters are available/accessible all over the report, so there should be no problem when using them in multiple report items/components.

    If you would like us to try to give you specific advises, please, open a support ticket and send us the problematic report so we can test it locally.

    Regards,
    Todor
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top