Multiple Controls in VS2010 After Quarterly Update

1 posts, 0 answers
  1. Eddie
    Eddie avatar
    1 posts
    Member since:
    Jul 2013

    Posted 03 Dec 2013 Link to this post

    I am placing this post in hopes that it may help someone else.

    I have experienced the same problem with multiple copies of controls showing up in the toolbox covered in this post. This is the most extensive post I found on the subject. The issue shows itself when adding in the next Quarterly Update. Each time you open VS2010 another copy of each toolbox section and tools will be created. The end result is that VS will start loading ever more slowly until it just crashes. I have had this problem most recently with Winforms Q3 2013. However, I have also experienced the problem with Asp.net Ajax. I have tried completely removing Telerik including deleting Telerik Folders under Programs. Removing Registry Entries, Reapplying Service Packs, Running VS2010 Repair and resetting the Toolbox with a right click of the mouse. I even ran a registry cleaner, Reinstalled Visual Studio and attempted without success to fully remove everything that VS2010 sticks on your computer. Don't even bother with the last one folks. It can get so fouled up that you want to pull out that little image disk you created and start fresh.

    After going through this circus a few times a ran across something that seemed to work. Actually it worked perfect for me. I just don't know if it will work for you. Before you go to the trouble to do all the things I did above and monkey with registry entries like suggested in the referenced post, simply go into VS2010. Select Tools and Extension Manager. Uninstall all Telerik Extensions. Close VS2010 and reboot your PC. Go back into extension Manager, Select Online Gallery and type in Telerik in the Search Bar. Select and install the package you are using. You may have to right click on the toolbox and Reset it. I hope this helps you.

Back to Top