This is a migrated thread and some comments may be shown as answers.

modal - background mask color?

4 Answers 211 Views
Window
This is a migrated thread and some comments may be shown as answers.
matt
Top achievements
Rank 1
matt asked on 01 Jul 2008, 05:35 PM
hello,

currently when the default RadWindow opens in modal=true mode, the mask over the background content appears to be a transparent whitish.

i would like this to be a transparent black, instead.

how is this done? ive checked the docs but if its there ive missed it.


thanks
matt

4 Answers, 1 is accepted

Sort by
0
Georgi Tunev
Telerik team
answered on 02 Jul 2008, 10:36 AM
Hi Matt,

You can use the IE Dev toolbar to check the class of the modal background - it is .TelerikModalOverlay.

Here is how to change the style so the background will be darker:

    <style type="text/css"
    .TelerikModalOverlay 
    { 
        filter: progid:DXImageTransform.Microsoft.Alpha(style=0,opacity=90) !important; 
        opacity: .9 !important;  
        -moz-opacity: .9 !important; 
    } 
     
    </style> 


Sincerely yours,
Georgi Tunev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
matt
Top achievements
Rank 1
answered on 02 Jul 2008, 07:22 PM
georgi,

thank you, but i dont think thats quite right. even at 100% (.1), that produces a solid color of *gray*, not black.

i have tried modifying like so:

.TelerikModalOverlay { 
    background:black
    filter:progid:DXImageTransform.Microsoft.Alpha(opacity=100) !important;  
    opacity:.1 !important;   
    -moz-opacity:.1 !important;  
}  

...which *used* to work in older versions of RadWindow; but that isnt working for me now.
0
Accepted
Georgi Tunev
Telerik team
answered on 03 Jul 2008, 07:40 AM
Hi Matt,

Note the !important directive at the end of the settings - this way you override the default ones sent from the server.
In addition, to make your background completely black, you need to set the opacity to 1, not 0.1:
.TelerikModalOverlay {  
    background:black !important;  
    filter:progid:DXImageTransform.Microsoft.Alpha(opacity=100) !important;   
    opacity:1 !important;    
    -moz-opacity:1 !important;   
}   



Greetings,
Georgi Tunev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
matt
Top achievements
Rank 1
answered on 03 Jul 2008, 10:21 PM
ah, "!important" did the trick -- i wasnt familar w/ that. brilliant!

thank you,
matt
Tags
Window
Asked by
matt
Top achievements
Rank 1
Answers by
Georgi Tunev
Telerik team
matt
Top achievements
Rank 1
Share this question
or