This is a migrated thread and some comments may be shown as answers.

Listbox no command controls.

1 Answer 19 Views
ListBox
This is a migrated thread and some comments may be shown as answers.
george mcnitt
Top achievements
Rank 1
george mcnitt asked on 12 May 2010, 08:29 PM
Trying to get the delete function to work with the RadListBox and I have met all the requirements according to the docs.

I have done all this.
  • Set the AllowDelete="True" (so the Delete button is visible)
  • Set the AllowAutomaticUpdates="True" (so the DataSource is updated automatically)
  • Set the AutoPostBackOnDelete="True".
  • Make sure that the DataSource has a DeleteCommand set.

I am using an SqlDataSource pointing to my table that has a primary key on the ID and userid fields.

The delete button displays in the listbox at design time but when I run the app there is no delete button. I have tried changing the width of the listbox but that did not help.

Is there something else I am missing that needs to be done?

1 Answer, 1 is accepted

Sort by
0
Genady Sergeev
Telerik team
answered on 14 May 2010, 11:55 AM
Hi george mcnitt,

Setting the AllowDelete property to true is sufficient in order to show the delete button. It seems that something is going wrong at your side. Do you have somekind of custom skinning? I am attaching test project to this replay which shows the delete button working. Can you reproduce the issue on it? Also, which version of RadListBox do you use?

Greetings,
Genady Sergeev
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
ListBox
Asked by
george mcnitt
Top achievements
Rank 1
Answers by
Genady Sergeev
Telerik team
Share this question
or