LinkManager Web.Config Missing Registration

3 posts, 0 answers
  1. Ken
    Ken avatar
    7 posts
    Member since:
    Jul 2010

    Posted 01 Jun 2011 Link to this post

    We've been using RadEditor with LinkManager  and now...suddenly it's quit working sometime within the last 2 releases? FF4 or IE9 same error dialog...

    "Web.config registration missing!
     The Telerik dialogs require a HttpHandler registration in the web.config file. Please, use the control's Smart Tag to add the handler automatically, or see the help for more information: Controls > RadEditor > Dialogs > Introduction"

    I have tried every single suggestion on this forum and searching the WWW to get the RadEditor LinkManager to not throw the "missing web.config" dialog.

    PLEASE do not point me to this almost 3 year old article...nothing works..
    http://www.telerik.com/support/kb/aspnet-ajax/editor/error-web-config-registration-missing-the-telerik-dialogs-require-a-httphandler-registration-in-the-web-config-file.aspx

    I have also tried referencing external dialog files..it still throws the same exception...so how do I debug or workaround the problem - write my own custome handlers?
  2. Rumen
    Admin
    Rumen avatar
    13804 posts

    Posted 03 Jun 2011 Link to this post

    Hi Ken,

    Is it possible to provide a live URL to the problematic page so that we can inspect the problem with Fiddler / Firebug? Please, also send via a support ticket the web.config file so that we can inspect it.

    You should also check the server error / events logs for any application restarts when the problem occurs.

    The problem could be due to some monitoring program such as WebSense or a Proxy server which decrease the URL length of the Dialog handler for example to 1700 symbols. To fix the problem contact your network administrator and increase the allowed URL length to 2000 symbols. You can find more information in these articles: Blank Dialogs Problem.



    Best regards,
    Rumen
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. Ken
    Ken avatar
    7 posts
    Member since:
    Jul 2010

    Posted 03 Jun 2011 Link to this post

    Solved, at least for our system

    When I called a web page with a RadEditor control on it with a querystring built like this..

    http://notarealurl.com/mytest.aspx/userid/fred

    I would get the "Web.Config Missing Registration" error thrown even though I verified we had the correct Web.Config settings

    If I pass the querystring like this...

    http://notarealurl.com/mytest.aspx?userid=fred

    The radeditor dialogs now work.

    Not sure if its something buried in http rewrite, or that the controls don't like..but this solved it for me.

    Thanks for your help.

Back to Top