Lightweight CSS should be fixed...

0 Answers 53 Views
TreeView
Hugo Augusto
Top achievements
Rank 2
Iron
Veteran
Iron
Hugo Augusto asked on 17 Feb 2023, 09:53 PM

Trying to use Lightweight mode but in current browsers it's now working properly and it's even unusable with RadTreeview.  I even tried to use your ThemeBuilder but the online sample gives bad results also.  Check the image from ThemeBuilder.

I'm using Windows 11, latest version of Edge.

Thank you

Rumen
Telerik team
commented on 22 Feb 2023, 05:08 AM

Thank you for bringing the rendering problem in the Material skin of the ThemeBuilder to our attention. We appreciate your effort to help us improve our app!

I just wanted to let you know that this issue seems to be limited to the Material skin within our app, and it might not affect and should work fine with the same and other skins or features in other projects.

If you have the time, could you please check if the issue is replicable in any of our online demos of the treeview control, which always has lightweight rendering turned on? Here's a link to the demos: https://demos.telerik.com/aspnet-ajax/treeview/examples/functionality/expandanimation/defaultcs.aspx?skin=Material

Also, if you have noticed the same problem occurring in other skins or features, please do let us know.

Lastly, if it's not too much trouble, could you share a Fiddler Jam capture with us? This would greatly help us to understand what might be causing the rendering problem in your application. Keep in mind that starting from a blank page or at least navigating to your page via the address bar is crucial for capturing all requests and responses:

https://docs.telerik.com/devtools/aspnet-ajax/knowledge-base/common-capture-issues-with-fiddler-jam  

Once again, thank you for your valuable feedback. We really appreciate it
Hugo Augusto
Top achievements
Rank 2
Iron
Veteran
Iron
commented on 22 Feb 2023, 12:46 PM

Hello Rumen,

I don't understand why you are sending me to the demos. I assume the ThemeBuilder is a valid example or not? The issue is not only in my application, it also happens in your application (ThemeBuilder) so that's a great starting point to check what's wrong.

Curiously, the Treeview UI errors only happen in ThemeBuilder when all the other controls are hidden. Please do the following steps to replicate:

1. Go to https://themebuilder.telerik.com/aspnet-ajax

2. Select Material them as the base

3. Check that the Treeview is rendered correctly.

3. In the Select Components, uncheck all except TreeView.

4. You will now get treeview with the same issues as in my image.

My version is 2020.1.114.40 but the issue still happens today.

Regards

Rumen
Telerik team
commented on 22 Feb 2023, 04:13 PM

Hi Hugo,

Please allow me to explain why I have sent you to the live demos. 

Usually the bug fixes happens in the latest version as explained in this article: https://docs.telerik.com/devtools/aspnet-ajax/upgrade-compatibility/old-versions-support-policy#bug-fixes

The version of the Theme Builder is not the latest one, it is 2022.1.119.45 and it might be due to a setting of the app but not a bug in the treeview control. This is something that we will investigate further.

The version of the live demos is the latest one 2023.1.117 and if the problem is not reproducible there, this means that it might be already fixed and you just need to upgrade from 2020.1.117 (which does not support the latest browsers) to the latest one.

I also wanted to see whether the problem in your app is the same as the one in the Theme Builder and asked you to record the issue in a Fiddler Jam capture so that I can examine it.

No answers yet. Maybe you can help?

Tags
TreeView
Asked by
Hugo Augusto
Top achievements
Rank 2
Iron
Veteran
Iron
Share this question
or