Issue in classic mode of Telerik v.2017.1.228.45

3 posts, 1 answers
  1. Gregory
    Gregory avatar
    6 posts
    Member since:
    Nov 2012

    Posted 12 Mar 2017 Link to this post

    You may see it on the official telerik web site: http://demos.telerik.com/aspnet-ajax/button/examples/rendermode/defaultcs.aspx?skin=Black

    Checkboxes and Radio are not properly visualized in the Classic Rendering mode.

    The issue is reproduced with any browser.

  2. Gregory
    Gregory avatar
    6 posts
    Member since:
    Nov 2012

    Posted 13 Mar 2017 Link to this post

    Fixed it by changing RadButton to RadCheckBox and RadRadioList telerik components.
  3. Answer
    Marin Bratanov
    Admin
    Marin Bratanov avatar
    4089 posts

    Posted 13 Mar 2017 Link to this post

    Hello Gregory,

    This is a known regression introduced in R1 2017 SP1. You can track its status and find the workaround you have already discovered in this page: https://feedback.telerik.com/Project/108/Feedback/Details/213217-radbutton-as-checkbox-checked-backgrounds-are-misplaced-in-classic-rendermode.

    I suggest you consider rolling back to R3 2016 SP2 release, because R1 2017 releases have a few other issues (you can find them here) and R3 2016 SP2 is the most stable one at this point, until these are fixed in R1 2017 SP2 and R2 2017.



    Regards,
    Marin Bratanov
    Telerik by Progress
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Back to Top