This is a migrated thread and some comments may be shown as answers.

Install Error for Telerik_Reporting_Q3_2010_SP1_TRIAL.msi on Windows 7 64 bit.

2 Answers 97 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Debajyoti
Top achievements
Rank 1
Debajyoti asked on 28 Jan 2011, 01:04 AM
I have Windows 7 64 bit. I have already installed Telerik Reporting Q2 2010. Now I want to install Telerik_Reporting_Q3_2010_SP1_TRIAL.msi.
It is throwing an error as "Need .Net 2.0 or Higher". It is exiting the installer. I have attached the screen shots.

Thanks,
Deba

2 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 28 Jan 2011, 01:45 PM
Hi Debajyoti,

As the error message states, you should install .NET 2 framework. Telerik Reporting is build against .NET 2.0 framework and it requires it.
 
To check the presence of the framework you should look at registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\NET Framework Setup\NDP\v2.0.50727

and then verify the existence of the entry value:

   Install (DWORD value = 1)

You can consult the MSDN article .NET Framework 2.0 Redistributable Package Reference for more details.

Greetings,
Steve
the Telerik team
Get started with Telerik Reporting with numerous videos and detailed documentation.
0
Debajyoti
Top achievements
Rank 1
answered on 28 Jan 2011, 07:55 PM
I already had .NET 2.0 , as it comes with Windows 7 64 bit prebuilt.  I had verified the .NET install status with microsoft provided verification tool. Then I tried again but I got the error again.
But surprisingly,
                       I got a workaround. First I installed RADAjax controls. It reconfigured .NET 2.0 Ajax framework. Then I restarted my laptop and then installed Telerik Reportting Q3 2010 SP1 Trial.

NOW, IT WORKED !!!!!!

Tags
General Discussions
Asked by
Debajyoti
Top achievements
Rank 1
Answers by
Steve
Telerik team
Debajyoti
Top achievements
Rank 1
Share this question
or