IE9 forced compatibility browser mode for RadScheduler

5 posts, 0 answers
  1. Jerry
    Jerry avatar
    70 posts
    Member since:
    Jan 2011

    Posted 10 Apr 2012 Link to this post

    Hi, i have a problem similar to a thread which was raised earlier last year (http://www.telerik.com/community/forums/aspnet-ajax/scheduler/radscheduler-in-ie8-compatibility-mode.aspx)

    I currently have a problem displaying the scheduler on our local intranet website where the scheduler will be shown incorrectly only on internet explorer.

    The page consists of one screen with a scheduler which should take up the whole space, but with Internet Explorer 9, it seems to get squished to the left hand side of the browser. After checking the internet tools, it seems that even though the document mode is forced to IE9, the browser mode is by default on "IE9 compatibility mode" which is what seems to be causing the problem.

    I have done research to see if i can turn off the compatibility mode programmatically but to no avail.

    One workaround i found was, even if the browser mode is on IE9 compatibility mode, if i had the document mode to be on IE7, the scheduler renders near correctly (the scheduler takes up the whole screen space but the grid lines are mis aligned with the dates on top) but the checkboxes i need are not rendered.

    Is there any solution to fixing this problem or get a better working workaround? It is going to be difficult to explain to users to go into their internet explorer settings to stop forcing of compatiblity view on their browsers.

  2. Plamen
    Admin
    Plamen avatar
    2925 posts

    Posted 11 Apr 2012 Link to this post

    Hi Jerry,

     
    This is a known issue with RadScheduler and you can find a CSS workaround in the Misalignments documentation topic. 

    Please excuse us for the inconvenience caused.

    Regards,
    Plamen Zdravkov
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Jerry
    Jerry avatar
    70 posts
    Member since:
    Jan 2011

    Posted 11 Apr 2012 Link to this post

    Wow Plamen, thanks for this fix, its working perfectly now!
  4. LJZIMMERMAN
    LJZIMMERMAN avatar
    6 posts
    Member since:
    Oct 2011

    Posted 15 May 2017 Link to this post

    This may be an issue again in 2017.1.118.45. Though the timeslots are displaying the proper number of slots, the time is mis-aligned and does not display the entire time period for a given day.  i.e., when the time period is 09:00 - 16:00, the display only displays 9, 10, 11, 12, 1 then stops.

     

    I am using IE 11.09.9600.78639

  5. Peter Milchev
    Admin
    Peter Milchev avatar
    464 posts

    Posted 18 May 2017 Link to this post

    Hello LJZIMMERMAN,

    As noted in the Browser Support article, the IE compatibility mode is not supported as of R3 2015. 

    If your issue persists with the latest R2 2017 release in Internet Explorer with disabled Compatibility mode, I would like to ask you to open an official support thread where you can provide more details on the configuration of the Scheduler and more detailed description and screenshots demonstrating the issue.

    Regards,
    Peter Milchev
    Telerik by Progress
    Try our brand new, jQuery-free Angular 2 components built from ground-up which deliver the business app essential building blocks - a grid component, data visualization (charts) and form elements.
Back to Top