This is a migrated thread and some comments may be shown as answers.

IE8 Browser becomes unresponsive when removing items from MultiSelect when bound to MVVM View Model - Kendo UI Q3 2013

1 Answer 12 Views
MultiSelect
This is a migrated thread and some comments may be shown as answers.
Dan Lewis
Top achievements
Rank 1
Dan Lewis asked on 07 Jan 2014, 11:13 AM
Hi,

I have a MultiSelect bound to part of my View Model using Kendo MVVM and the declarative binding syntax which for the most part is working great. However, I have noticed that when removing items from the MultiSelect in IE8 the browser becomes unresponsive. This happens in IE8 native and in emulated modes are far as I can tell and seems to do this in the latest Q3 2013 builds also.

I have put together a simple example on JS Bin: http://jsbin.com/UJOxUqa/1/

I have tried with the Q2 2013 version and it seems to work OK (http://jsbin.com/OcAHuQEW/1/), so it looks like something may have been introduced in Q3?

We are due to go to pilot next week where the user base is all IE8, so if there is not a quick or obvious workaround I am guessing I will have to revert to Q2?

Any help greatly appreciated...

Regards,

Dan.

1 Answer, 1 is accepted

Sort by
0
Kiril Nikolov
Telerik team
answered on 07 Jan 2014, 01:15 PM
Hello Dan,

This is a known issue that we are currently working on. The fix will be available with the Q1 Service Pack release scheduled for January 16th.

Regards,
Kiril Nikolov
Telerik
Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
Tags
MultiSelect
Asked by
Dan Lewis
Top achievements
Rank 1
Answers by
Kiril Nikolov
Telerik team
Share this question
or