how to set radeditor's language

3 posts, 0 answers
  1. Chris
    Chris avatar
    3 posts
    Member since:
    Jun 2011

    Posted 14 Jun 2011 Link to this post

    Hi,

    I need to set the language of the spellchecker to Dutch and so far I'm unsuccessful.

    I've downloaded a file with translations (nl-NL.tdf) from http://www.telerik.com/community/forums/aspnet-ajax/spell/147971-radspell-dictionaries.aspx
    I tried to follow the way they described it here: http://blogs.telerik.com/blogs/posts/10-04-30/localizing_the_radeditor.aspx:
    • I've planted it into the project's ~/App_Data/RadSpell/ directory.
    • I've added this in the web.config:
      		<httpHandlers>
      			<add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>
      			<add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
      		</httpHandlers>

      and another one into <system.webServer>:
    		<handlers>
    			<add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>
    			<add name="Telerik.Web.UI.SpellCheckHandler" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" />
    		</handlers>
    • my radEditor looks like this:
      <telerik:RadEditor ID="reEditor" runat="server" SkinID="DefaultSetOfTools" Height="400px" Width="100%" ContentAreaCssFile="~/App_Themes/_generic/RadEditorContent.css">
      	<Languages>
      		<telerik:SpellCheckerLanguage Code="nl-NL" Title="nl-NL" />
      	</Languages>
      	<Content></Content>
      </telerik:RadEditor>
    Still nothing. Could you tell me what am I missing?
  2. Slav
    Admin
    Slav avatar
    1359 posts

    Posted 14 Jun 2011 Link to this post

    Hello Chris,

    This is how I enabled RadSpell with language set to Dutch. I added RadEditor to my project, put the translations file (nl-NL.tdf) in the appropriate folder(~/App_Data/RadSpell/), then I enabled RadSpell from RadEditor's Smart Tag (Enable spell check for RadEditor option). After this is set, I added SpellCheckSettings tag inside RadEditor, where is specified the resource file for spell check. On your page it will look like this:
    <telerik:RadEditor ID="RadEditor1" runat="server">
            <SpellCheckSettings DictionaryLanguage="nl-NL" />
    </telerik:RadEditor>

    Furthermore, if you want to set multiple languages for spell checking, you should use Languages Collection as in the next example:
    <telerik:RadEditor ID="RadEditor1" runat="server">
        <Languages>
            <telerik:SpellCheckerLanguage Code="fr-FR" Title="French" />
               <telerik:SpellCheckerLanguage Code="nl-NL" Title="Dutch" />
        </Languages>
    </telerik:RadEditor>

    Here you can find article on the matter, to help you better understand what you need to do.

    If you want to localize the RadEditor, you should supply localization resource files to ~/App_GlobalResources folder. Follow the link below to find list with available resource files:
    http://www.telerik.com/community/forums/aspnet-ajax/editor/radeditor-for-asp-net-ajax-localizations.aspx

    Next, to choose language for RadEditor, set it in the Language property of the Control.
    <telerik:RadEditor ID="RadEditor1" runat="server" Language="nl-NL">
            <SpellCheckSettings DictionaryLanguage="nl-NL" />
    </telerik:RadEditor>
    In this article you will find additional information on Global Resource Files.

    I have attached a fully working sample project to give you better understanding of the solution.

    Best wishes,
    Slav
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  3. Chris
    Chris avatar
    3 posts
    Member since:
    Jun 2011

    Posted 17 Jun 2011 Link to this post

    Thanks a lot, it works
Back to Top