How to disable...

3 posts, 1 answers
  1. Jorge
    Jorge avatar
    2 posts
    Member since:
    Aug 2013

    Posted 06 Jun 2014 Link to this post


    How can I disable these multiple features from the diagrams?

    1. Draggable objects
    2. Dynamic connectors (the ones that you add once the diagram is already rendered)
    3. Zooming with the mouse scroll
    4. Ctrl+Z effect

    Thank you!
  2. Answer
    Iliana Nikolova
    Iliana Nikolova avatar
    2622 posts

    Posted 10 Jun 2014 Link to this post

    Hi Jorge,

    Straight to the questions
    1. Basically the draggable option can be used for this requirement, however there is a bug in the current version of Kendo UI Diagram and it does not work. We are working on it and will do our best to address it as soon as possible;
    2. This requirement is not supported at this point and there is no a suitable workaround I can suggest;
    3. Setting zoomRate to will disable the zooming (documentation link);
    4. I am afraid this requirement is also not supported, however we will consider it for future releases.

    Iliana Nikolova
    Join us on our journey to create the world's most complete HTML 5 UI Framework - download Kendo UI now!
  3. Gabbi
    Gabbi avatar
    4 posts
    Member since:
    Jan 2015

    Posted 21 Nov 2017 in reply to Iliana Nikolova Link to this post

    Disabling the zoomRate to 0 did the work. 
Back to Top