This is a migrated thread and some comments may be shown as answers.

How do I get my Telerik Controls on my toolbar

13 Answers 59 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jerry
Top achievements
Rank 1
Jerry asked on 23 Oct 2008, 05:15 PM
I installed the controls and opened the sample file and within the toolbar it shows RadControls for ASPNET AJAX.  When I open an existing project it doesn't show me.  I'm not sure how to add it?

Thank you for any help
Jerry

13 Answers, 1 is accepted

Sort by
0
Daniel
Telerik team
answered on 23 Oct 2008, 05:35 PM
Hello Jerry,

Please examine the following links:
Adding RadControls to the Visual Studio 2005 Toolbox
Adding RadControls to the Visual Studio 2008 Toolbox
Adding RadControls to an ASP.NET WebForm

Regards,
Daniel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Jerry
Top achievements
Rank 1
answered on 23 Oct 2008, 05:42 PM
Daniel,
Thank You I will look through them. 
I will remove the support ticket I sent through.  I was in a hurry and I needed an answer. 

Thank You
0
Jerry
Top achievements
Rank 1
answered on 23 Oct 2008, 06:35 PM
Daniel,
That didn't work.  I even tried the dll from the bin and I got an error.
It said
"There was an error loading types from assembly 'C:\Progarm Files\Telerik\RadControls for ASPNET AJAX Q2 2008\Bin\Telerik.Web.UI.dll' 'Could not load file or asssembly 'System.WebExtensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToen=31bf3856ad364e35 or one of its dependencies. The system cannot find the file specified.

Any help?

I'm trying to add it an existing .net 2.0 project

Thank You
Jerry
0
Vlad
Telerik team
answered on 24 Oct 2008, 06:50 AM
Hi Jerry,

Do you have System.WebExtensions 1.0 installed on this machine?

Greetings,
Vlad
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Jerry
Top achievements
Rank 1
answered on 24 Oct 2008, 01:21 PM
Vald,
Where can I go to verify?
I tried installing ASP.NET AJAX 1.0 but it said I already have something installed and it couldn't continue.

Thanks for your reply
Jerry
0
Sebastian
Telerik team
answered on 24 Oct 2008, 01:27 PM
Hi Jerry,

Make sure that you installed the ASP.NET AJAX 1.0 version and the System.WebExtensions assembly is added to the GAC. Also verify that your site is configured to be AJAX-enabled:

http://ajax.asp.net/docs/ConfiguringASPNETAJAX.aspx

Best regards,
Stephen
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Jerry
Top achievements
Rank 1
answered on 24 Oct 2008, 01:47 PM
Stephen ,
I have all that installed but what I did notice in the Gac is that my System.WebExtensions are version 3.5.0.0.  the error says 
Version=1.0.61025.0.   I have gotten the controls to work on a .net 3.5 project but still not 2.0.

Thanks
Jerry
0
Daniel
Telerik team
answered on 24 Oct 2008, 02:12 PM
Hello Jerry,

Please try the attached web.config file and let us know whether the mentioned error disappears.

Regards,
Daniel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Jerry
Top achievements
Rank 1
answered on 24 Oct 2008, 02:35 PM
Daniel,
I'm getting my error message when i'm trying to add the controls to my toolbox within the development enviroment.  I don't think the web contfig will play any role in this issue.

I just want to use the controls within a .net 2.0 project.

Thanks
Jerry
0
Daniel
Telerik team
answered on 24 Oct 2008, 03:06 PM
Hello Jerry,

Could you please try to install the AJAX extensions again and then let us know the exact message of the error you faced. This will help us to provide more to-the-point answer.

ASP.NET AJAX Downloads

Regards,
Daniel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Jerry
Top achievements
Rank 1
answered on 24 Oct 2008, 04:28 PM
I figured it out.  I uninstalled the atlas version and installed ASP.NET AJAX 1.0.

Thanks again everyone for your help.

Jerry
0
Simon Holman
Top achievements
Rank 1
answered on 24 Oct 2008, 10:04 PM
I find that if I open a web application (with a project file) I see the Telerik controls. If I open a website folder, I don't get the Telerik controls. If I go to add them into the toolbox using the methods described, they are already showing in the .Net Framework Components list.
How can I fix this as I mostly use website folders.
0
Simon Holman
Top achievements
Rank 1
answered on 25 Oct 2008, 04:05 AM
Nevermind, I fixed the problem. The website was set to asp.net 2.0 not 3.5
Tags
General Discussions
Asked by
Jerry
Top achievements
Rank 1
Answers by
Daniel
Telerik team
Jerry
Top achievements
Rank 1
Vlad
Telerik team
Sebastian
Telerik team
Simon Holman
Top achievements
Rank 1
Share this question
or