This is a migrated thread and some comments may be shown as answers.

Hovering Images in Rotator

2 Answers 29 Views
Rotator
This is a migrated thread and some comments may be shown as answers.
Jeff
Top achievements
Rank 1
Jeff asked on 12 May 2010, 09:17 PM

I have a rotator within a user control.  The content size of the screen is being set via JavaScript with scroll bars turned on.  The browser scroll bars are turned off so not to confuse the user with two sets.  The images within the rotator work just fine except for one major issue.  The image “hovers” over the page and does not position itself within the rotator.  Only when the browser scroll bars are active and the content scroll bars are turned off does the image behave correctly.  Attached is the code and any assistance would be greatly appreciated.

<telerik:RadRotator ID="thumbRotator" runat="server" RotatorType="ButtonsOver" Height="120px" Width="600px" ItemHeight="120px" ItemWidth="150px" FrameDuration="1" ScrollDuration="500" ScrollDirection="Left,Right" EnableEmbeddedSkins="false" OnItemClick="ShowImage">  
<ItemTemplate> 
<div style="text-align:center; padding:20px;">  
<asp:Image ID="imgRotator" runat="server" Height="50px" Width="50px" ImageUrl='<%# DataBinder.Eval(Container.DataItem,"Source") %>' /> 
<br /> 
<%# DataBinder.Eval(Container.DataItem, "TypeDescription")%> 
<br /> 
(<%# DataBinder.Eval(Container.DataItem, "Size")%>)  
</div> 
</ItemTemplate> 
<ControlButtons LeftButtonID="img_left" RightButtonID="img_right" /> 
</telerik:RadRotator> 
 

2 Answers, 1 is accepted

Sort by
0
Fiko
Telerik team
answered on 17 May 2010, 12:42 PM
Hello Jeff,

I see that you disable the embedded skins. Do you experience the same behavior with the Default skin, without setting the EnableEmbeddedSkins="false" property? If the problem still exists using the Default skin, could you please open a new support ticket and sends me the project which shows the problem? I will check it and do my best to provide a working solution as soon as possible. Also, please provide me with information about the browser which you use.

All the best,
Fiko
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Jeff
Top achievements
Rank 1
answered on 17 May 2010, 02:45 PM
Fiko,

We decided to go with a different route and disable the scroll bars within the page content section and use the browser's scroll bars.  This allowed the rotator to work as expected.  Thanks for you reply.
Tags
Rotator
Asked by
Jeff
Top achievements
Rank 1
Answers by
Fiko
Telerik team
Jeff
Top achievements
Rank 1
Share this question
or