This is a migrated thread and some comments may be shown as answers.

History back & Inputs and Buttons

12 Answers 91 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Erick
Top achievements
Rank 2
Erick asked on 07 Aug 2013, 01:44 PM
Hi,

I am using your RadInputs and RadButtons for our subscribe application. I have an issue with history back and automatic restore of the historical data in the form. When i fill some textboxes and togglebuttons, go to other page (link or redirect) and go back with history back, the data in textboxes will be restored as expected but it seems it's thinking it's empty and shows the data as emptymessages and will be lost after next postback. The state of togglebuttons will not be restored. 

I tried with normal html inputs and this will be restored correctly. 

We need this because the users will go back to correct the data sometimes.
Is this an known issue?

See for example
http://screencast.com/t/wnUnvPxo

Tested this in Chrome.

Thanks.
Jelle

12 Answers, 1 is accepted

Sort by
0
Erick
Top achievements
Rank 2
answered on 07 Aug 2013, 01:54 PM
And can reproduce this at your demos as well.
http://demos.telerik.com/aspnet-ajax/input/examples/overview/defaultcs.aspx

- Fill some values in name and age fields.
- Click on 'password strength checker'
- Go to back with history back
- The filled values are restored as expected
- Uncheck Client Side Validation
- All fields are empty!

It seems the values in hidden INPUT objects are restored correctly but in the RadInputs temorary until next postback.
Bug?
0
Eyup
Telerik team
answered on 12 Aug 2013, 07:04 AM
Hi Jelle,

Thank you for contacting us.

Our developers are aware of this issue and currently working on a fix. The updated internal build with the actual fix is expected to be available in a week or two.

Please wait for the mentioned update and the problem should be resolved. Sorry for any inconvenience caused.

Regards,
Eyup
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Erick
Top achievements
Rank 2
answered on 12 Aug 2013, 12:02 PM
Thanks for your answer,
We will wait for the internal build.

Jelle
0
Erick
Top achievements
Rank 2
answered on 02 Sep 2013, 12:12 PM
Any news about this?
0
Eyup
Telerik team
answered on 05 Sep 2013, 08:56 AM
Hi Jelle,

I will forward your query to the dev team responsible for the mentioned fix and let you know about the result when I get a response.

Regards,
Eyup
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Fabio
Top achievements
Rank 1
answered on 17 Sep 2013, 08:35 AM
Same problem here

controls lose the viewstatus when I make this type of navigation:

1) I insert the values
2) redirect response
3) back => values ​​there are still
4) again redirect
5) back => values ​​are no longer there

I read about a workaround suggest by you where we need to use hiddenfields for each control in the page.

But it is prohibitively expensive for a site that is based more on telerik controls.
In addition, the pages become extremely heavier because the pages, with the hiddenfields added, get heavier.

Please, give highest priority to the resolution of this issue.  

Thank you very much!
Fabio
0
Eyup
Telerik team
answered on 17 Sep 2013, 09:56 AM
Hello,

The developers team responded that the issue was fixed. You can download and upgrade to the latest internal build and the problem should be resolved.

Regards,
Eyup
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Fabio
Top achievements
Rank 1
answered on 17 Sep 2013, 10:02 AM
Sorry but I'm yet using 2013.2.717

And the issue is still here.
0
Eyup
Telerik team
answered on 20 Sep 2013, 08:42 AM
Hello Fabio,

You need to download and upgrade to the latest internal build:
http://www.telerik.com/account/your-products/internal-builds.aspx.

Hope this helps.

Regards,
Eyup
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Stefano
Top achievements
Rank 1
answered on 20 Sep 2013, 01:57 PM
now it works

thank you!!
0
Erick
Top achievements
Rank 2
answered on 17 Oct 2013, 09:31 AM
Is this issue fixed in Q3 2013 version too?
0
Eyup
Telerik team
answered on 22 Oct 2013, 06:42 AM
Hello Erick,

Yes, it should be included in the mentioned latest release version.

Regards,
Eyup
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Tags
General Discussions
Asked by
Erick
Top achievements
Rank 2
Answers by
Erick
Top achievements
Rank 2
Eyup
Telerik team
Fabio
Top achievements
Rank 1
Stefano
Top achievements
Rank 1
Share this question
or