This is a migrated thread and some comments may be shown as answers.

hide the expand collapse column in radgrid

9 Answers 882 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Allen
Top achievements
Rank 1
Allen asked on 02 May 2013, 12:55 PM
Hi
    How to hide  the expand collapse column in radgrid. I have set hierarchydefaultexpand to true. I dont want to collapse the expanded rows.
thanks
Allen

9 Answers, 1 is accepted

Sort by
0
Princy
Top achievements
Rank 2
answered on 02 May 2013, 01:04 PM
Hi,

Please try the following CSS.

CSS:
<style type="text/css">
.rgExpandCol {
   display:none !important;
}
</style>

Thanks,
Princy.
0
Kerry
Top achievements
Rank 1
answered on 19 Jul 2013, 06:34 PM
This ALMOST works for me. The header and main body column is gone, but my filter row still has the column. So I end up with the attached image.
0
Princy
Top achievements
Rank 2
answered on 22 Jul 2013, 07:03 AM
Hi Kerry,

Please try the following CSS code snippet to achieve your scenario.

CSS:
<style type="text/css">
 .rgExpand, .rgCollapse
  {
    display: none;
  }
</style>

Hope this helps.

Thanks,
Princy
0
Kerry
Top achievements
Rank 1
answered on 22 Jul 2013, 01:37 PM
That actually ended up doing nothing for me.

I DID, however, locate a solution FOR ME. My situation is that I simply do NOT want to see the expand/collapse column EVER. For some odd reason, my non-hierarchical records are showing up with Expand column on load. Upon postback, the column disappears.

My solution can be done in either the apsx page or in the codebehind.

apsx:
<MasterTableView ExpandCollapseColumn-Visible="false">


Codebehind (VB):
RadGrid.MasterTableView.ExpandCollapseColumn.Visible = False

0
BestCoder
Top achievements
Rank 1
answered on 27 Mar 2014, 04:52 AM
Your post was uber-helpful. But how did learn about this property? It doesn't appear in intellisense.

     ExpandCollapseColumn-Visible="false"The property

Wondering why this doesn't appear in the Telerik documentation for the radGrid. The only mention of this property is this:

"The property setter does nothing and should not be used. It works around a bug in the VS.NET designer."

Danny
0
Princy
Top achievements
Rank 2
answered on 28 Mar 2014, 11:24 AM
Hi,

You can get this from intellisense of  the Telerik:Radgrid tag.

ASPX:
<telerik:RadGrid ID="RadGrid1" runat="server"
MasterTableView-ExpandCollapseColumn-Display
="false">

Thanks,
Princy
0
Manish
Top achievements
Rank 1
answered on 30 Sep 2015, 05:58 AM

 It was quite helpful. 

Thanks Kerry

 

 

0
Johnathan
Top achievements
Rank 1
answered on 08 Oct 2015, 02:38 PM

Hi Kerry,

 I'm not sure why this is, but the expandcollapsecolumn option doesn't work for me (I can set the visible property to false, but the expand/collapse column still appears). I was able to create a CSS workaround for those who may have the same issue:

#<%=RadGrid1.ClientID%> .rgGroupCol { display:none !important;}

Thanks,

 Johnathan Beam

0
Eyup
Telerik team
answered on 13 Oct 2015, 11:19 AM
Hello Johnathan,

You can also hide the column on code-behind:
http://www.telerik.com/forums/hide-group-expand-collapse-columns-in-radgrid#gwiwEE8eFkuo43JFSlSlZw

Hope this helps.

Regards,
Eyup
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Grid
Asked by
Allen
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 2
Kerry
Top achievements
Rank 1
BestCoder
Top achievements
Rank 1
Manish
Top achievements
Rank 1
Johnathan
Top achievements
Rank 1
Eyup
Telerik team
Share this question
or