This is a migrated thread and some comments may be shown as answers.

Hide filter for uniqueId

1 Answer 20 Views
Filter
This is a migrated thread and some comments may be shown as answers.
Javier
Top achievements
Rank 1
Javier asked on 15 Jul 2019, 09:49 PM

     Hello!

 

I recently started using RadFilter control instead of the filters that were inside the radgrid, but I can't get to hide the uniqueId on the RadFilter options even though it doesn't show on my radgrid.

 

I am building dinamically my radgrid, so I am not sure where to write or if it is possible to set "allowFiltering to false"

 

I am attaching an image where it shows "unique Id" as a filter option even though it doesn't show up as a column on my radgrid

 

Thanks in advance!

1 Answer, 1 is accepted

Sort by
0
Attila Antal
Telerik team
answered on 18 Jul 2019, 02:46 PM
Hi Javier,

Try disabling the filtering for the columns you do not want to list in the RadFilter options. Set its AllowFiltering property to false.

Example:

<telerik:GridBoundColumn DataField="OrderID" DataType="System.Int32" AllowFiltering="false"
    FilterControlAltText="Filter OrderID column" HeaderText="OrderID"
    ReadOnly="True" SortExpression="OrderID" UniqueName="OrderID">
</telerik:GridBoundColumn>

Result:





Kind regards,
Attila Antal
Progress Telerik
Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
Tags
Filter
Asked by
Javier
Top achievements
Rank 1
Answers by
Attila Antal
Telerik team
Share this question
or