This is a migrated thread and some comments may be shown as answers.

GridBoundColumn

3 Answers 48 Views
Grid
This is a migrated thread and some comments may be shown as answers.
mww
Top achievements
Rank 1
mww asked on 31 Oct 2008, 09:38 AM

When displaying data in my grid, some of the columns are split over 2 lines.  How can I force the display on 1 line only ?  there are no carriage returns in the data.  Ive displayed the columns like this.

<telerik:GridBoundColumn   
                                        DataField="Tel"   
                                        HeaderText="Tel"   
                                        SortExpression="Tel" 
                                        UniqueName="Tel">  
                                    </telerik:GridBoundColumn> 

3 Answers, 1 is accepted

Sort by
0
Shinu
Top achievements
Rank 2
answered on 31 Oct 2008, 10:25 AM
Hi Mark,

Hope you are trying to prevent wrapping of the cell text. If so refer the following help article which explains how to prevent wrapping in Grid columns.
No wrap for grid cell content

Shinu.



0
mww
Top achievements
Rank 1
answered on 31 Oct 2008, 07:33 PM
That worked OK for the cell contents, but If the header text is longer than the cell contents, the header text wraps.  How can I prevent this ?
0
Dimo
Telerik team
answered on 03 Nov 2008, 06:36 AM
Hi Mark,

Since Internet Explorer does not support disabled text wrapping by default, you need to do this:


1) Enable RadGrid sorting


2) Add the following CSS rules to your web page or website:


.GridHeader_SkinName
{
    overflow: hidden;  /*needed by Firefox*/
}
.GridHeader_SkinName  a
{
    white-space: nowrap;  /*needed by IE*/
}



Kind regards,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
mww
Top achievements
Rank 1
Answers by
Shinu
Top achievements
Rank 2
mww
Top achievements
Rank 1
Dimo
Telerik team
Share this question
or