This is a migrated thread and some comments may be shown as answers.

Grid auto-edit mode

1 Answer 43 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Jim
Top achievements
Rank 1
Jim asked on 24 Nov 2008, 10:35 PM

I've got a radGrid that I've put into edit mode for all rows using the PreRender method (by setting the editableitem.edit property).

It works well...all the rows in the grid are in edit mode...except all the rows are highlighted in the Skin's color (in my case, the Vista skin, so the rows are light blue).  All I I want to do is have them show up without the highlight.

 

So, I've tried editableItem.selected = false, but this does not un-highlight the rows.  I've also tried setting the editableItem.style property, all to no avail.  What am I missing?

 

Any advice is appreciated.

1 Answer, 1 is accepted

Sort by
0
Accepted
Princy
Top achievements
Rank 2
answered on 25 Nov 2008, 04:45 AM
Hello Jim,

Try setting the BackColor to transparent in the EditItemStyle for the grid as shown below:
aspx:
 <telerik:RadGrid ID="RadGrid1" DataSourceID="SqlDataSource2" Skin="Vista" AllowMultiRowEdit="true" runat="server" OnPreRender="RadGrid1_PreRender" > 
  <EditItemStyle BackColor="Transparent" /> 
  <MasterTableView> 
    .... 

Thanks
Princy.
Tags
Grid
Asked by
Jim
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 2
Share this question
or