This is a migrated thread and some comments may be shown as answers.

Global Custom Skin

3 Answers 119 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Curt
Top achievements
Rank 1
Curt asked on 17 Jul 2008, 03:42 PM
I have seen where I can set a global skin (in the webconfig) for a control.  Can this be done with custom skins as well?  I have tried it for a grid.  The grid displayed correctly until I went to add/edit a record then all of the controls in the edit section (radcombobox, radnumberictextbox, radeditor) were all missing their images.  Is there something else I need to do to get this to work?

<appSettings>
  <add key="Telerik.Grid.Skin" value="DWDS"/>
    <add key="Telerik.Editor.Skin" value="DWDS"/>
    <add key="Telerik.Input.Skin" value="DWDS"/>
  </appSettings>

3 Answers, 1 is accepted

Sort by
0
Dimo
Telerik team
answered on 18 Jul 2008, 08:48 AM
Hi Brent,

Yes, custom skins can be declared in web.config as well.

When you are using RadControls for the RadGrid automatic editing (RadComboBox, RadInput, etc), these controls inherit their skin name from RadGrid. However, they do not register their CSS skins automatically, that is why you need to do that. You have two options -

1) register the CSS skins for the controls separately on the page with <link> tags or place them in the ASP.NET theme that you are using.

2) add the CSS skins to some existing and already registered CSS files (for example the global web application stylesheet or the RadGrid skin CSS file).


Let us know if you need more information.


Greetings,
Dimo
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Curt
Top achievements
Rank 1
answered on 18 Jul 2008, 04:23 PM
I tried adding the skin I had for my radcombobox into my skin for the radgrid but it didn't seem to work.  I am also already declaring the <link> files for all of the telerik controls in my master page.  This works if you tell each control which skin to use but I can't get it to work if I add the entry in the web.config and then remove the <link> tags from the master page. 

Could you give an example.

Thanks
0
Dimo
Telerik team
answered on 21 Jul 2008, 04:18 PM
Hello,

<link> tags for non-embedded skins are required (unless you use an ASP.NET theme), so only setting a skin name in the web.config is not enough.

If you still have problems, could you please open a support ticket and send us a simple working project for us to investigate locally? Thanks.

Regards,
Dimo
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
General Discussions
Asked by
Curt
Top achievements
Rank 1
Answers by
Dimo
Telerik team
Curt
Top achievements
Rank 1
Share this question
or