Full Screen mode has no scroll bars when AutoResizeHeight="true" property is set

4 posts, 0 answers
  1. Ross Miles
    Ross Miles avatar
    5 posts
    Member since:
    May 2008

    Posted 17 Oct 2011 Link to this post

    As the thread title suggest when I have the AutoResizeHeight="true" property set on a RadEditor field and press the toggle full screen mode with content's height that exceeds the height of the screen, the scroll on the RadEditor does not appear.
    If i do not have this property set the full screen works correctly. I can also replicate this on the online demo here

    http://demos.telerik.com/aspnet-ajax/editor/examples/autoresizeheight/defaultcs.aspx

    Any assistance would be appreciated.

     

  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 18 Oct 2011 Link to this post

    Hello Ross,

    This is the expected behavior. When the AutoResizeHeight property is set to true, then the editor's content area is resizing to match content height and no scrollbars will appear.The value of the AutoResizeHeight property indicates whether the RadEditor will auto-resize its height to match content height.

    Thanks,
    Shinu.
  3. Ross Miles
    Ross Miles avatar
    5 posts
    Member since:
    May 2008

    Posted 18 Oct 2011 Link to this post

    Hi Shinu,

    What you have described does occur when the RadEditor is not in Full Screen mode. When you have content that exceeds the height of the browser window when this property is set there is no scroll. I have attached screenshots of what I'm talking about
  4. Rumen
    Admin
    Rumen avatar
    14459 posts

    Posted 20 Oct 2011 Link to this post

    Hello Ross Miles,

    The problem is not trivial and we are still working on it. My suggestion is to disable either Full Screen Mode or the Auto Height Expand feature until we fix the problem.

    You can disable the ToggleScreenMode shortcut (F11) using the following code:

    <script type="text/javascript">
    function OnClientLoad(editor, args) {
    editor.removeShortCut("ToggleScreenMode");
    }
    </script>
    <telerik:radeditor runat="server" OnClientLoad="OnClientLoad" ID="RadEditor1"></telerik:radeditor>


    All the best,
    Rumen
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
Back to Top