This is a migrated thread and some comments may be shown as answers.

Firefox ignore widht for columns

1 Answer 27 Views
Grid
This is a migrated thread and some comments may be shown as answers.
ManniAT
Top achievements
Rank 2
ManniAT asked on 06 Aug 2008, 02:22 PM
Hi,

I have a grind which displays some data columns.
On column is a hyperlink - sometimes quite long.

I set the widht of this colunm to 120px.

With IE works as expected - but not so with firefox.
Even setting

word-break

:break-all;
word-wrap:break-word;

makes no difference. Since the URL has no blanks - FF does not break the line.

Any iedea how to solve this without using templates and divs or something like this?
I'm a bit arfraid that running application may have the same "good look" if sometimes I have longer strings.

From my point of view "wide range of browser compatibility" means - I set the width - and the control makes the things gooing.
Even by omitting divs or what ever is needed to solve a simple task like a grid with column width set in design.

Regards

Manfred

1 Answer, 1 is accepted

Sort by
0
Dimo
Telerik team
answered on 07 Aug 2008, 12:32 PM
Hello Manfred,

Firefox does not support the word-break and word-wrap CSS properties. This browser also does not split words if they do not fit in their containers.

The only thing that you can do in this case is to set TableLayout="Fixed" for the MasterTable and hide the content, which overflows out of the table cells by using a simple CSS rule:


.MasterTable_Skin  td
{
     overflow: hidden;
}


Another option, of course is not to display the URLs directly in the HyperLink column, but some other text instead. When the user clicks on the text, he still will be navigated to the desired location.


All the best,
Dimo
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Grid
Asked by
ManniAT
Top achievements
Rank 2
Answers by
Dimo
Telerik team
Share this question
or