This is a migrated thread and some comments may be shown as answers.

Firebird and ScriptManager

2 Answers 64 Views
ScriptManager and StyleSheetManager
This is a migrated thread and some comments may be shown as answers.
Oscar
Top achievements
Rank 1
Oscar asked on 14 Nov 2013, 03:57 PM
I have the following problem:
I am developing in Visual Studio 2010 (ASP.Net and Visual Basic) and I use Firebird 2.5, the Firebird Client 3.1 dll. Using RadGrid and SQLDataSource controls, I have no trouble using Firebird, I can do inserts, updates and deletes, but I need to refer to the Firebird library, and when running the application generates RadScripManager error. The error is as follows:
Could not load type 'System.Runtime.CompilerServices.ExtensionAttribute' from assembly 'mscorlib, Version = 4.0.0.0, Culture = neutral, PublicKeyToken = b77a5c561934e089'.
But remove the reference and project works again

2 Answers, 1 is accepted

Sort by
0
Peter Filipov
Telerik team
answered on 19 Nov 2013, 05:03 PM
Hi Oscar,

I have tested a sample project with FirebirdSql.Data.FirebirdClient.dll and everything is working fine. Could you please send me your sample project to investigate it locally. In order to narrow down the problem please try to use the StandardScript manager. Test your application and let me know the results.

Regards,
Peter Filipov
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Oscar
Top achievements
Rank 1
answered on 27 Dec 2013, 05:21 PM
It solved the problem, I had to reformat my laptop, make installation of all software (visual studio, telerik and firebird), perhaps references (firebird ado.net) the machine.config file is damaged, this solution worked me, and I could use Telerik, no problem. thanks
Tags
ScriptManager and StyleSheetManager
Asked by
Oscar
Top achievements
Rank 1
Answers by
Peter Filipov
Telerik team
Oscar
Top achievements
Rank 1
Share this question
or