This is a migrated thread and some comments may be shown as answers.

Error When Trying to do Alternating Row Item Styles

1 Answer 18 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Rob
Top achievements
Rank 1
Rob asked on 31 Oct 2012, 07:25 PM
We have a dynamic report object builder.

Within the building report method, I create a Formatting Rule as per:  http://www.telerik.com/help/reporting/faq-alternating-style.html  I then add that formatting rule to the table on the report.

However when I try to view any reports I see the following error:  Aggregate node 'LeafNumber(Const(RowNumber))' not found.

I'm wondering before I create a test project if anything like this has been seen before.  I did see this forum thread:   http://www.telerik.com/community/forums/reporting/telerik-reporting/error-expression-contains-undefined-function-call-leafnumber.aspx  However, it doesn't seem applicable and doesn't appear to have gone anywhere.

Thanks for any insight or help.

1 Answer, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 05 Nov 2012, 02:52 PM
Hello Rob,

We would definitely need more info in order to get to the bottom of this, please post at least the expression for the formatting rule, so we can verify whether it is correct or not. As mentioned in the forum thread you referred to, it would be best to provide us with a runnable sample that exhibits the issue.

All the best,
Steve
the Telerik team

HAPPY WITH TELERIK REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

Tags
General Discussions
Asked by
Rob
Top achievements
Rank 1
Answers by
Steve
Telerik team
Share this question
or